WordPress.org

Forums

Trouble installing on a Mac OS X 10.6.3 (19 posts)

  1. mousebert
    Member
    Posted 5 years ago #

    I am trying to set-up WordPress on a Mac MacOS x 10.6.2 and I am stuck. I am using MAMP and used a tutorial at http://www.recordpc.com/mac-os-x-snow-leopard-install-local-wordpress-using-mamp and I am down to #7 which says:

    Now open your working WordPress site and finish the configuration.

    Which pretty much means nothing to me. Also in setting up the database, it wants the number of fields, and I have no idea what to enter.

    I can open the readme file at: http://localhost:8888/wordpress/readme.html

    And see the the following

    Installation: Famous 5-minute install
    1. Unzip the package in an empty directory.
    2. Open up wp-config-sample.php with a text editor like WordPad or similar and fill in your database connection details.
    3. Save the file as wp-config.php
    4. Upload everything.
    5. Open /wp-admin/install.php in your browser. This should setup the tables needed for your blog. If there is an error, double check your wp-config.php file, and try again. If it fails again, please go to the support forums with as much data as you can gather.
    6. Note the password given to you.
    7. The install script should then send you to the login page. Sign in with the username admin and the password generated during the installation. You can then click on 'Profile' to change the password.

    OK, line 5 doesn’t do anything. I have tried opening in FireFox and Safari. Firefox does nothing or gives an error and Safari just shows the php code.

    What do I do from here?

    
Thank you

  2. esmi
    Forum Moderator
    Posted 5 years ago #

    Sounds like your server isn't set up correctly.

  3. mousebert
    Member
    Posted 5 years ago #

    OK, now what?

  4. What happens when you go to http://localhost:8888/wordpress

  5. mousebert
    Member
    Posted 5 years ago #

    I get a blank page.

  6. Are you sure PHP is working and turned on? IIRC you have to have MAMP on for it to work.

  7. Col Kav
    Member
    Posted 5 years ago #

    Hi ,
    i was having the exact same troubles, hoping i'm not stating the obvious here, but this, after a couple hours of trying all sorts of things, file editing etc, worked for me. Just type:
    http://localhost:8888/
    Bingo. It's so easy when you know

  8. mousebert
    Member
    Posted 5 years ago #

    When typing in http://localhost:8888/ from Safari, I get:

    Index of /

    Name Last modified Size Description
    wordpress/ 25-May-2008 15:33 -
    Apache/2.0.63 (Unix) PHP/5.2.11 DAV/2 Server at localhost Port 8888

    MAMP is on with the green lights on.
    When I click PHPinfo from http://localhost:8888/MAMP/?language=English, I get this plus far too much below to cut-n-paste:

    PHP Version 5.2.11

    System Darwin Office-2.local 10.3.0 Darwin Kernel Version 10.3.0: Fri Feb 26 11:58:09 PST 2010; root:xnu-1504.3.12~1/RELEASE_I386 i386
    Build Date Dec 12 2009 13:14:57
    Configure Command './configure' '--with-mysql=/Applications/MAMP/Library' '--with-apxs2=/Applications/MAMP/Library/bin/apxs' '--with-gd' '--with-jpeg-dir=/Applications/MAMP/Library' '--with-png-dir=/Applications/MAMP/Library' '--with-zlib' '--with-freetype-dir=/Applications/MAMP/Library' '--prefix=/Applications/MAMP/bin/php5' '--exec-prefix=/Applications/MAMP/bin/php5' '--sysconfdir=/Applications/MAMP/conf/php5' '--with-soap' '--with-config-file-path=/Applications/MAMP/conf/php5' '--enable-track-vars' '--enable-bcmath' '--enable-ftp' '--enable-gd-native-ttf' '--with-bz2=/usr' '--with-ldap' '--with-mysqli=/Applications/MAMP/Library/bin/mysql_config' '--with-sqlite' '--with-ttf' '--with-t1lib=/Applications/MAMP/Library' '--enable-mbstring=all' '--with-curl=/Applications/MAMP/Library' '--enable-dbx' '--enable-sockets' '--enable-bcmath' '--with-imap=shared,/Applications/MAMP/Library/lib/imap-2007e' '--enable-soap' '--with-kerberos' '--enable-calendar' '--with-pgsql=shared,/Applications/MAMP/Library/pg' '--enable-dbase' '--enable-exif' '--with-libxml-dir=/Applications/MAMP/Library' '--with-gettext=shared,/Applications/MAMP/Library' '--with-xsl=/Applications/MAMP/Library' '--with-pdo-mysql=shared,/Applications/MAMP/Library' '--with-pdo-pgsql=shared,/Applications/MAMP/Library/pg' '--with-mcrypt=shared,/Applications/MAMP/Library' '--with-openssl'
    Server API Apache 2.0 Handler
    Virtual Directory Support disabled
    Configuration File (php.ini) Path /Applications/MAMP/conf/php5
    Loaded Configuration File /Applications/MAMP/conf/php5/php.ini
    Scan this dir for additional .ini files (none)
    additional .ini files parsed (none)
    PHP API 20041225
    PHP Extension 20060613
    Zend Extension 220060519
    Debug Build no
    Thread Safety disabled
    Zend Memory Manager enabled
    IPv6 Support enabled
    Registered PHP Streams https, ftps, compress.zlib, compress.bzip2, php, file, data, http, ftp
    Registered Stream Socket Transports tcp, udp, unix, udg, ssl, sslv3, sslv2, tls
    Registered Stream Filters zlib.*, bzip2.*, convert.iconv.*, string.rot13, string.toupper, string.tolower, string.strip_tags, convert.*, consumed

  9. Col Kav
    Member
    Posted 5 years ago #

    In MAMP, under preferences->Apache->Document Root , have you set this to the location of your wordpress files?

    I put the whole wordpress folder in there, so it looks like this for me:
    /Users/username/Sites/wordpress

    No need to edit any of the wordpress files.

    It should be as simple as that, once all set just hit Open Start Page in MAMP and you should be prompted...
    If it doesn't work maybe try setting a different default browser, like firefox.

    I'm new to this so if it's anything more complicated then i don't know, i'm afraid. Good luck

  10. mousebert
    Member
    Posted 5 years ago #

    When I click Open Start Page in MAMP I get

    Welcome to MAMP
    If you can see this page, MAMP is installed
    on your Mac and everything is working!

    It is the link from there that I got the previous information.

    Obviously, I am new at this. So what do I do next? Buy a book on PHP and MySQL or WordPress for Idiots?

    BTW, I have DreamWeaver and a bit of experience with html. In the remote pass, I have a strong programming experience, pre-OOPS, so I should be able to handle coding. Biggest draw back is time to do it.

    Thanks!

  11. mousebert
    Member
    Posted 5 years ago #

    BUMP

    So what do I do next?

  12. What do you get when you go to: http://localhost/~shortusername/ ?

  13. mousebert
    Member
    Posted 5 years ago #

    I get the standard apache webpage for the Mac:
    ______________________________________________

    Mac OS X Logo
    Your website here.

    Now you can use Mac OS X Personal Web Sharing to publish web pages or share files on the Internet — or on your company’s (or school’s) local area network — from a folder on your hard disk.

  14. When you run phpinfo in MAMP as above, do you get a formatted page with gray and purple and text in columns, or just plain, unformatted, black and white text? If it's plain text, php is broken. If so, check the MAMP forums.

  15. mousebert
    Member
    Posted 5 years ago #

    OK, I think I am lost here. I get an entirely different page with http://localhost/~shortusername/ than http://localhost:8888/MAMP/?language=English

    Clicking the phpinfo from the page that is opened from the MAMP app Open start page (http://localhost:8888/MAMP/?language=English) gives me the php page that I partially cut-n-pasted above. Most of it is gray and lavender, but there are some multicolored fields. The following are in color.

    highlight.bg #FFFFFF #FFFFFF
    highlight.comment #FF8000 #FF8000
    highlight.default #0000BB #0000BB
    highlight.html #000000 #000000
    highlight.keyword #007700 #007700
    highlight.string #DD0000 #DD0000

  16. localhost/~shortusername/ is the built-in apache webserver in OS X. (You can drop a phpinfo file in that directory, delete the Apple index page and you'll get a directory listing and can select phpinfo).

    localhost:8888/MAMP is the one you installed with MAMP.

    (Sorry, but I don't know why people use MAMP when you get a better result with stock OS X and MySQL).

    So php is working under MAMP. Sounds like you either you're not looking for the right directory where WP is under http://localhost:8888/

    Or something else is broken with MAMP. I'd check their forums.

  17. Thomas TG
    Member
    Posted 5 years ago #

    I had a tough time installing this on a Mac as well. I am not based in programming but I figured that I would try to do this since I use WP at work and am trying to learn it on my own.

    So, here's what I found and it worked.

    If you want pictures (which I did) Install Local WordPress using MAMP does a great job of showing you step by step. However, you might have got stuck on #6 and not realize it.

    It says under mySQL database hostname to enter: 'localhost8889'
    Don't.

    WordPress site Installing WordPress Locally on your Mac with MAMP says just to enter 'localhost' (down at the bottom).

    Of course, make sure you follow the previous steps. Once you are done, go to your local site (mine is localhost:8888/wordpress/wp-admin/install.php) and do their 5 minute setup.

    wordpress = name of my database

    I am new to this but I got it to work after suffering through what you described. If anyone notices something that is not correct, feel free to chime in.

  18. mousebert
    Member
    Posted 5 years ago #

    Thanks.

    When I have the time, I will try this.

  19. mousebert
    Member
    Posted 5 years ago #

    Thomas TG,

    That appears to have basically worked. That and seeing I dropped a ' at the end of define('DB_NAME', 'wp-database');

    DOH!

    I now have the wordpress welcome page.
    Thanks

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.