Support » Installing WordPress » Trouble Installing both thru FTP & Browser

  • Resolved Bijoubean


    I can’t seem to install. First changed and uploaded the wp-config file manually and got:

    We were able to connect to the database server (which means your username and password is okay) but not able to select the weblog_global database.

    * Are you sure it exists?
    * Does the user weblog have permission to use the weblog_global database?
    * On some systems the name of your database is prefixed with your username, so it would be like username_weblog_global. Could that be the problem?

    If you don’t know how to set up a database you should contact your host. If all else fails you may find help at the WordPress Support Forums.

    I checked and double checked that DB info was entered correctly and then tried to install through the browser by deleting the wp-config file. Yet when I attempted to install I got this:

    Sorry, I need a wp-config-sample.php file to work from. Please re-upload this file from your WordPress installation.

    Another blog was set up successfully with the same host.

    Please help!

Viewing 6 replies - 1 through 6 (of 6 total)
  • Emil Uzelac


    Theme Review Admin

    Upload wp-config-sample.php and try again.

    Hi Emil,

    I am facing the same issue as described by Bijoubean above till the point of re-uploading wp-config.php with correct db and user details.
    Are there any workaround scenarios in such a case?


    A lot of it depends on your webhost and how they configure options or the control panel that you use. I know that I use cPanel and that when I setup a database a name is added in front of the name of the database as well as the database user that I set.

    So if I set the database and username to something like example and the name of the account for my hosting is jarret, the actual name of the database and the username for the database would be jarret_example.

    I know I’ve run into this situation a few times myself and couldn’t figure out why I couldn’t get WordPress to find the right database. Maybe this is a possible solution to your issue?

    Here’s a strange development. I tried to install WP on a another domain (same webhost) that I had already successfully installed a different blog. Lo and behold I was able to install the new blog but after entering the dashboard, realized that I had mistakenly installed a previous version. Well…after updating to 3.0.4, I encountered the same issues as before. Back to square one.

    Could it still be an issue w/ the webhost since I was previously able to install on the same account…albeit an older version of WP?

    So version 3.0.4 doesn’t work but previous versions of WordPress do work? I’m not aware of any major changes that were introduced into 3.0.4 that would cause requirements to change. I believe 3.1 may introduce some new requirements but that isn’t out yet.

    Just so I’m clear, you setup a new WordPress installation on a separate domain using the same webhosting account. You were able to set and install WordPress and log into your Dashboard but once you upgraded to 3.0.4 you received the error that WordPress could no longer connect to the database?

    Jerrett – that is correct.

    I have since resolved the issue. If anyone is having the same problem, it is due to the server setup with php4. Once I upgraded to php5 and added a .htaccess file to the root with following line, (AddType x-mapp-php5 .php), everything worked dandy with the added bonus that I am now able to upgrade versions and themes automatically in the admin instead of manually.

    It appears to be an easy fix. You may have to contact your host but I was able to change the version of php thru my control panel.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Trouble Installing both thru FTP & Browser’ is closed to new replies.