Support » Installing WordPress » Trouble installing

  • Resolved JanetW

    (@janetw)


    I understand HMTL extenstively, but I know nothing about PHP and MySQL, so I’m having great difficulty understanding how to get WordPress set up. I am not sure I have the right information in my wp_config.php file. I am not exactly sure where the changes should be made and what the answers should be.

    Did I do this right and is there anything else on this that needs to be changed?

    <?php
    // ** MySQL settings ** //
    define(‘DB_NAME’, ‘peggysjournal’); // The name of the database
    define(‘DB_USER’, ‘peggysjournal’); // Your MySQL username
    define(‘DB_PASSWORD’, ‘****’); // …and password
    define(‘DB_HOST’, ‘localhost’); // 99% chance you won’t need to change this value

    // You can have multiple installations in one database if you give each a unique prefix
    $table_prefix = ‘wp_’; // Only numbers, letters, and underscores please!

    // Change this to localize WordPress. A corresponding MO file for the
    // chosen language must be installed to wp-includes/languages.
    // For example, install de.mo to wp-includes/languages and set WPLANG to ‘de’
    // to enable German language support.
    define (‘WPLANG’, ”);

    /* That’s all, stop editing! Happy blogging. */

    define(‘ABSPATH’, dirname(__FILE__).’/’);
    require_once(ABSPATH.’wp-settings.php’);
    ?>

    I am getting this error message: Your PHP installation appears to be missing the MySQL which is required for WordPress.

    I am doing this for a friend and her website is hosted at Godaddy.

    Thanks so much!

    Janet

Viewing 12 replies - 1 through 12 (of 12 total)
  • Thank you anyway… found the answer and thank you!!

    This is exactly my problem. Using GoDaddy Linux servers and windows XP local PC. I have double checked the name of my SQL server and login credentials.

    I saved the file (see end of message) in notepad with this name “wp-config.php” and ‘no file type’ then tried to run install with this file either in the ftp
    1) route directory,
    2) the blog folder (ie directory with all wordpress content as unzipped)
    3) the word-press wp-admin folder.

    Same error each time.

    a long message from your support that starts: wp-config.php file. I need this before we can get started. Need more help? We got it. You can create a wp-config.php file through a web interface….

    HELP!

    wp-config.php file contents:
    <?php
    // ** MySQL settings ** //
    define(‘DB_NAME’, ‘WeHome’); // The name of the database
    define(‘DB_USER’, ‘WeHome’); // Your MySQL username
    define(‘DB_PASSWORD’, ‘password’); // …and password
    define(‘DB_HOST’, ‘localhost’); // 99% chance you won’t need to change this value

    // You can have multiple installations in one database if you give each a unique prefix
    $table_prefix = ‘wp_’; // Only numbers, letters, and underscores please!

    // Change this to localize WordPress. A corresponding MO file for the
    // chosen language must be installed to wp-includes/languages.
    // For example, install de.mo to wp-includes/languages and set WPLANG to ‘de’
    // to enable German language support.
    define (‘WPLANG’, ”);

    /* That’s all, stop editing! Happy blogging. */

    define(‘ABSPATH’, dirname(__FILE__).’/’);
    require_once(ABSPATH.’wp-settings.php’);
    ?>

    Mark (podz)

    (@podz)

    Support Maven

    If you are hosting on Godaddy, this line is wrong:
    define('DB_HOST', 'localhost');

    On GD, that line is something like this:
    define(‘DB_HOST’, ‘mysql34.secureserver.net’);`

    As for the other problem, are you certain the files are in teh correct place and were uploaded in ASCII mode ?

    Im having the same problems on GD i changed the DB_HOST to mysql34.secureserver.net and i still get the “Your PHP installation appears to be missing the MySQL which is required for WordPress” error message.

    JANET IF YOU COULD POST WHAT YOU DID TO FIX THIS THAT WOULD BE GREAT.

    I’ve added the right server address (found by logging into Godaddy’s management center and getting information on my SQL servers).
    Verified the ‘case’ of all my text entries.
    Used the awesome .php form to create the wp-config.php file file.
    But still its not recognised – I’m not even getting off the ground

    Any ideas what might be blocking me?

    wendy:

    Is your wp-config.php recognised as a php file? You can use yoru ftp tool to right-click on the file and look at the properties. Coz thats the only thing wrong I can think of.

    warm regards,

    Yep properties (on the ftp server) say its a php file.

    I’ve placed all the wordpress files in a single folder called ‘blog’. I’ve maintained the folder structure that was delivered within the opened zip file. Do you think that ‘flattening the folder sturcture might help (ie taking the folders and files to the route directory might help?) I’ll try that next, then contact godaddy support and post their response on this thread. Thanks for making me feel slightly sensible!

    W

    SOLVED! by accident.

    WRONG (what I did): once the wp-config file had accurate details and was loaded on ftp://domain.com I then navigated to the install file and double-clicked on it within the ftp:// space. Got error

    RIGHT: open the public place (counter intuitive) http://www.domain.com and the WordPress set-up flow kicks off

    After I’d discovered this set-up was a BREEZE, importing RSS feeds from a previous MSN Spaces Blog was a BREEZE, its all going splendidly. Thank you so much for writing wonderful free-ware and proactively supporting it

    I want to MARRY all of you 🙂

    response to wendy’s solution:

    maybe the installation help could clarify this. Techies would understand that you cant just double click on the install file from ftp itself but for non-techies, I dont quite think they would be aware of that. They may consider the installation the same as installing an exe file and double click it. anyone?

    warm regards,

    Hi,

    I am trying to install. I run the php install script and i get the step one screen– enter the name and email… it then goes to a step 2 screen that says it is going to install sample tables and data but it just stops dead there. no error, no completion message. any ideas?

    Okay…I did all the above. I edited the wpconfig accurately, with the right localhost for GoDaddy but STILL I am getting the: Your PHP installation appears to be missing the MySQL which is required for WordPress, error.

    I activated a mySQL server yesterday and on my GoDaddy account page the status is “setup”. This was 24 hours ago….does setup mean it’s active, or does it have to say active?

    I totally agree with Veena. Suggest WP install guidelines specify that the config file should be fun by opening the http:// domain. I was following the instructions and assuming that the file would behave like and .exe file. Who do we give this information to?

    Baysider – you descirbe exactly the error I got when attempting to fun the Install from within my Browser fointing at the (ftp://webserverdomain, rather than pointing at the http://www.domain

    Gerben1980
    With my working set-up I see the name of the Database with the option to ‘open manager’ – this is where I see it

    Login to GoDaddy account management pages. Click on
    ‘Hosting & Email’, select my hosting account, click on ‘open’, Scroll down until I see “Databases”, click on MySQL.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Trouble installing’ is closed to new replies.