WordPress.org

Ready to get started?Download WordPress

Forums

Trouble Importing "Too Old" WXR File (21 posts)

  1. jamalge
    Member
    Posted 3 years ago #

    So basically, I keep running into issues trying to import an old WordPress.com blog that I exported to an XML file. Every time I try to import it, it gets all my authors, but says in a grey bar at the top:

    This WXR file (version 1.2) may not be supported by this version of the importer. Please consider updating.

    When I ignore this, assign the old authors to my new user accounts, that's where I always run into trouble. It simply doesn't work. I don't think it has anything to do with the size of the file, as the file is only 3.1MB and GoDaddy says my maximum is 8MB.

    What am I doing wrong here? Is there a way to "upgrade" my XML (/WXR) file so it can be handled by the version of WordPress Importer that I'm using?

    Thanks so much, can give any more details if needed...

  2. Emily-Alice
    Member
    Posted 3 years ago #

    I'm not sure if this is going to help you but I ran into the same problem this morning. The page seemed to load at first saying it has assigned the posts to the current user but then had no sign that it was finished. I ended up refreshing the page several times and resending the info until eventually it came up with a message at the bottom saying 'All done - Have fun'.

    That seemed to work for me and my posts have been imported. Maybe it will help you too.

    Good luck!

  3. michelnewel
    Member
    Posted 3 years ago #

    I got exactly the same message today jamalge, although everything was importing except my posts. My file was even smaller than yours. I tried refreshing many times. I even got the 'All done - Have fun' message. It wasn't all done.

    Finally, I deactivated and deleted the Importer plug-in, and installed version 0.2 from here: http://wordpress.org/extend/plugins/wordpress-importer/download/

    However, it still didn't seem to be working - all I could see were media files downloading, then it seemed to freeze (which had happened previously). I then went back to Emily-Alice's strategy and refreshed my screen over and over and over again, and it finally worked. I could have kissed my screen!

    I hope it works for you too!

  4. gripnrip
    Member
    Posted 3 years ago #

    I cannot import my export file either, the posts do but the media all fails.

    I am hardly surprised, this is an area that wordpress seem to place no importance on, I have been trying to migrate from posterous to wordpress for weeks, its awful.

  5. lan_dawei
    Member
    Posted 3 years ago #

    @Emily-Alice.
    Which browser did you use?

    I'm trying to import data from a client who set up her blog at WordPress. I'm transferring to GoDaddy. The file size is 5.3 MB, so I believe I am within size limit. I don't know which version of WordPress she is using and I've searched all over her Dashboard. I'm trying to import into WP 3.3.1.

    When I uploaded with Chrome, I really don't get any useful information.
    When I uploaded with FireFox, it gave me this title message:

    "This WXR file (version 1.2) may not be supported by this version of the importer. Please consider updating."

    Followed by:
    Assign Authors

    To make it easier for you to edit and save the imported content, you may want to reassign the author of the imported item to an existing user of this site. For example, you may want to import all the entries as admins entries.

    If a new user is created by WordPress, a new password will be randomly generated and the new user’s role will be set as subscriber. Manually changing the new user’s details will be necessary.

    Import author: ***** ******* (******) (I blanked out her name)
    or create new user with login name:
    or assign posts to an existing user:

    Import Attachments

    Download and import file attachments

    I've tried the upload perhaps a dozen times, but have not tried the refresh approach.

    Any other suggestions?

  6. lan_dawei
    Member
    Posted 3 years ago #

    I tried to export an XML file from my blog to a local MAMP WordPress installation. I ran into a similar situation. Since it was a local installation, I had nothing to lose, so I selected "admin" next to the textbox that said: "assign posts to an existing user".

    *That* worked!

    However, I have been attempting to get that same message again from my client's dashboard, but it hasn't come back???!!!!

    This is very frustrating not only to me, but to my client as well.

    And WordPress support has yet to get back to me!

  7. Emily-Alice
    Member
    Posted 3 years ago #

    @lan_dawei

    I was using FireFox too when I got the message. I don't think that the updating message is referring to the WordPress program - on wordpress.com I was never asked to update - I think it is automatic since they host the blogs. It's only when you are self hosting the software that you seem to have to manually update.

    I have no idea about your latest problem I'm afraid! I just got lucky with the refresh button. Are you past the point where you could try it?

  8. lan_dawei
    Member
    Posted 3 years ago #

    @Emily-Alice.

    Yes, I'm past the point. I managed to get the blog to load, but the entire effort was frustrating for both me and my client.

    I blogged about this effort at:
    http://i-wanna-start-a-blog.com/blogging/why-i-recommend-self-hosting-wordpress/

  9. wouterdutoit
    Member
    Posted 3 years ago #

    Hi guys, I have been setting up a site on a domain, and am struggling with the migration process. I am experiencing exactly the same as most of you in the thread.

    I am a newby, so I need to ask: does the WordPress Support employees ever get back to queries on these forums, because it's been about a week since the last post with no solution?

  10. lan_dawei
    Member
    Posted 3 years ago #

    I don't know. You get what you pay for and WordPress.org really has not financial incentive to respond. I sent two queries last week and all I got was "your e-mail is in cyberspace" nonsense.

    I've found I've received more WordPress support from customer support at my ISP!

    If you know of anyone who is thinking about using WordPress hosting, talk them out of it! Having them use WP on a self-hosted account. There are far fewer hassles. In the end, time is money!

  11. le20avril
    Member
    Posted 2 years ago #

    hi...
    just change 1.2 to 1.1 in the xml file. that worked for me...
    cheers

  12. lan_dawei
    Member
    Posted 2 years ago #

    @le20avril.

    I created a local WP testcase to try this out.

    Yeah, I changed <wp:wxr_version>1.2</wp:wxr_version> to
    <wp:wxr_version>1.1</wp:wxr_version>. It got rid of
    the error banner/message that appeared at the top.

    I had to define the user as admin, and then when I started the actual import, I saw a number of error messages that said it was not read or imported (sorry, don't have the exact message now), but when it was all done, checked the import and was successful.

    Thanks!!

  13. bhamono
    Member
    Posted 2 years ago #

    Thank-you very much for providing this solution. I waited two weeks for a helpful repl on the thread I started.

    http://wordpress.org/support/topic/wordpress-331-import-from-com-site-not-working

  14. kristaswan
    Member
    Posted 2 years ago #

    I've encountered the same message, "This WXR file (version 1.2) may not be supported by this version of the importer. Please consider updating."
    but everything was up to date.

    I re-assigned the users, hit import, and it gives me a bunch of text saying that all of my files already exist (probably because I've tried this 30 times already...). So if the files exist, why aren't they publishing, and why can't I see them??

  15. I am a newby, so I need to ask: does the WordPress Support employees ever get back to queries on these forums, because it's been about a week since the last post with no solution?

    To clarify something. The support on the forums is free, provided by mostly volunteers. So no, you don't get a promise of a reply.

  16. kurageart
    Member
    Posted 2 years ago #

    Hitted my head on this too.
    The quite obvious solution, was to go on
    http://wordpress.org/extend/plugins/wordpress-importer/download/
    and download and install (uploading) the DEV version
    It makes a lot of sense, since the plugin complains that the importer (and not the file) haves a too old format.

  17. lan_dawei
    Member
    Posted 2 years ago #

    @kurageart.

    Why is using the developer's version an "obvious solution"? I would think it would
    be in a state of flux.

    Best regards,
    lan_dawei

  18. connex91
    Member
    Posted 2 years ago #

    The solution from Kurageart works great! Solved all my issues. I was trying to move from the free hosted blog to my own hosted site.

  19. shannonsouth
    Member
    Posted 2 years ago #

    To expand on le20avril's comment:

    Change line 34 in the xml file from 1.2 to 1.1 - like this:
    <wp:wxr_version>1.2</wp:wxr_version>
    change to
    <wp:wxr_version>1.1</wp:wxr_version>

    It worked perfectly for me.
    Good luck!

  20. You could do that or just upgrade to the current WordPress importer 0.6.

    0.6

    Support for WXR 1.2 and multiple CDATA sections
    Post aren't duplicates if their post_type's are different

    http://wordpress.org/extend/plugins/wordpress-importer/changelog/

  21. shannonsouth
    Member
    Posted 2 years ago #

    I actually have Importer 0.6 - but it still didn't work. :(

Topic Closed

This topic has been closed to new replies.

About this Topic