Support » Plugin: Bebop » Trouble getting Twitter working

Viewing 15 replies - 1 through 15 (of 25 total)
  • Plugin Author Dale Mckeown

    (@dalemac)

    Hi,

    Yes, you need to register an application on Twitter and use the token/secret it will provide to you.

    oAuth works by authenticating the application first, and then authenticating the user based on twitter login sessions. This means you can only add one account to the Twitter/Facebook extensions per user. All other extensions can have multiple accounts.

    All documentation is on our Github wiki (https://github.com/lncd/bebop/wiki).

    The ‘RSS Enabled’ checkbox is for publishing RSS feeds from Bebop – it is not a method of import.

    Dale

    @dalmac

    Dale,

    Thank you for the reply. I read the documentation on github prior to posting. It does not mention setting up a Twitter app or how to do so. I’d be happy to add that to the Bebop documentation now that I know how.

    The Twitter app page provides two sets of keys, Consumer Key and Secret and Access Token and Secret.

    In Bebop I entered the Access Token and Secret.

    In the Accounts page receive the error when clicking on Twitter: Failed to validate oauth signature and token
    http://www.redline.cc/bug/tYy7vaab

    I entered them again just to be sure.

    Any thoughts?

    [ Signature moderated. ]

    Plugin Author Dale Mckeown

    (@dalemac)

    Hi Eric,

    You need the tokens labelled “Consumer Key” and “Consumer Secret” for twitter.

    Any help on documentation would be welcomed, if not, i will write it when i get round to it.

    Thanks,

    Dale

    Dale,

    Glad to help on documentation once I get all of the parameters correct. I think that Bebop is a very necessary tool for creating a vibrant learning communities. Thank you for creating it.

    For this Twitter issue I entered the Consumer Key and Consumer Secret into Content Providers Twitter Import Settings page.

    On the Resources/Accounts/Twitter Setup pages I receive the following error: /oauth/request_token?oauth_callback= (balance is a long string)
    http://www.redline.cc/bug/QPzwHaab

    [ Signature moderated. ]

    As a follow through I did click the Start Authorization button but nothing happens. When I hover over the button it displays: http://
    Start Authorisation

    but it does not appear to append the display string. Should the auth string be exposed on the member page like this in clear text?

    [ Signature moderated. ]

    Plugin Author Dale Mckeown

    (@dalemac)

    Hi Eric,

    That’s odd.

    Possible because you previously entered an incorrect token/secret. I would advise clearing the ‘bp_bebop_user_meta’ through your webhost database admin panel and then try again.

    I will have a look at how i can prevent this in the future.

    Dale

    I can check that but I think the data is correct in the database. It shows correctly when I view the Content.

    I disabled and re-enabled the plugin.The settings show up correctly.

    I tested the Resources/Accounts/Twitter setup again and got this error this when clicking the Start Authorisation button.
    http://www.redline.cc/bug/Py6d4aab

    It appears that the string is not being passed to the script.

    [ Signature moderated. ]

    Plugin Author Dale Mckeown

    (@dalemac)

    Hi Eric,

    Disabling and re-enabling the plugin does nothing.

    Twitter is a pain because it requires an automatic temporary oauth token/secret to be made. If this was made with an incorrect consumer token/secret, you will get the problems you are experiencing.

    Hence, you need to clear the temporary oauth token/secret from the table i mentioned above.

    Dale

    Dale,

    I do not see a table named, ‘bp_bebop_user_meta’
    I am self hosted and looking in phpMyAdmin…

    [ Signature moderated. ]

    Dale,

    I found it. Mine is wp_bp_bebop…

    There is no data in meta_value for either bebop_twitter_oauth_token_temp or bebop_twitter_oauth_token_secret_temp

    From what I can see the auth string is not being appended to the url properly for some reason. Only the base string is being submitted to twitter: api.twitter.com/oauth/authorize?oauth_token=

    This is what I see on the member screen: http://www.redline.cc/bug/g1cNGaab

    [ Signature moderated. ]

    Plugin Author Dale Mckeown

    (@dalemac)

    Odd. I suggest you uninstall bebop completely and then reinstall.

    Dale

    Dale,

    I removed the plugin and dropped the associated tables. Then re-installed.

    Same result. The full string is not being passed to twitter.

    Is the Resource/Accounts/Twitter screen supposed to show this long string to the user? http://www.redline.cc/bug/g1cNGaab

    [ Signature moderated. ]

    Plugin Author Dale Mckeown

    (@dalemac)

    Hi Eric,

    Thanks for trying that.

    No, the long string is not supposed to show, this means an exception was encountered when generating the temporary access tokens. I initially thought this was due to the incorrect keys being saved to the database, but with a fresh install and correct consumer key/token i would not suggest there is something not set right in your twitter application.

    Please check that the app’s access level is set to read/write, and the callback URL points to your domain.

    Dale

    Dale,

    The Twitter app was set to read only. I changed it to Read and Write but we won’t be writing to Twitter anyway, correct?

    Also, the callback URL. What should that be? I try to enter just the domain name it does not save it.

    Under Callback URL The Twitter site says:
    “OAuth 1.0a applications should explicitly specify their oauth_callback URL on the request token step, regardless of the value given here. To restrict your application from using callbacks, leave this field blank.”

    [ Signature moderated. ]

    Ah, wait. I was able to get it to Authorize! I can see my Tweets!

    However, Bebop does not work with Twitter the way I thought it would. I expected users to be able to enter their Twitter handle and have their tweets come into their or the sites Activity Stream.

    Is that possible? Right now it seems that only one user will work at time?

    [ Signature moderated. ]

Viewing 15 replies - 1 through 15 (of 25 total)
  • The topic ‘Trouble getting Twitter working’ is closed to new replies.