WordPress.org

Support

Support » Plugins and Hacks » Trouble getting Moderation to work

Trouble getting Moderation to work

  • I am having trouble getting the moderation feature for Simplr Registration Form Plus+ to work. I have “Enable Moderation” set to “Yes” and approval mode set to “Manual”, yet when a user fills out the registration form I created, they are automatically assigned to a role (in this case subscriber) instead of me having to manually approve them. Is there something I am missing, or does this not actually work how I’m thinking it does? I assumed moderation meant the user would receive an e-mail with the moderation message, and a site admin would have to manually adjust their role in the WordPress admin.

    http://wordpress.org/extend/plugins/simplr-registration-form/

Viewing 15 replies - 1 through 15 (of 27 total)
  • I have the same problem. I want the Admin to be able review and activate the account before the user gets anything.

    Me three.

    Did either of you find a fix for this? I have not. Thanks.

    Plugin Author mpvanwinkle77

    @mpvanwinkle77

    Hey guys, sorry for the delay on this. I’ve been slammed at work. Looking into this now.

    Plugin Author mpvanwinkle77

    @mpvanwinkle77

    Yes, moderation is broken, working on a fix today and tomorrow, should have it out by wednesday.

    Glad to see its not something I was doing…
    I was just about to post to say I was having the same problem as the above when I noticed the Plugin Author had already commented.

    So instead I will say it’s a very nice plugin mpvanwinkle77 and I look forward to the fix.

    Plugin Author mpvanwinkle77

    @mpvanwinkle77

    Ok, just pushed out the moderation fix. Please give it a try.

    Hi Mike,

    Thanks for pushing out the moderation fix as promised. It seems to be working well on my system.

    I was wondering if there is anyway that there could be a message on the form page just in case a user decides to try to login without having been authorised yet.
    Perhaps something like ‘Your account is yet to be authorised. Please wait until your authorisation email is sent to you from our administrator..’
    It’s just an idea.

    Thanks again for the fix.

    Plugin Author mpvanwinkle77

    @mpvanwinkle77

    Good idea, I’ll make that editable on the next version.

    Great!
    Glad to hear the suggestion was useful:-)

    That’s a good suggestion Ebo1233.

    Now when a non-authorised wants to login there is a default empty red error box.

    Plugin Author mpvanwinkle77

    @mpvanwinkle77

    Can you take a screenshot of the “empty” error box. There should be a message there.

    When I disable the plugin and try to login with wrong password I also get an empty red error box. So I think it’s my WP installation…

    Hi,

    I really appreciate for developing this extremely useful and such a easy to use plug-in. I was able to integrate most of the features within couple of hours end-to-end. Now i’ve the registration page with all the fields up and running.

    But the moderation is still seem to be broken. I’ve tested it. It doesn’t ask the admin for moderation. It creates the new user without moderation. Can you please help?

    I’m using Simplr User Registration Form Plus version 2.2.3.

    Really appreciate your help

    Thanks !!

    I also have problems with the moderation – it is assigning the user role without asking for approval from an admin!!

    but the new user cannot login and an admin has no way of approving the new user!!.

    Using the latest version of the plugin

Viewing 15 replies - 1 through 15 (of 27 total)
  • The topic ‘Trouble getting Moderation to work’ is closed to new replies.