Support » Fixing WordPress » Trouble displaying international characters after upgrade to 3.0

  • namho

    (@namho)


    I recently upgraded to 3.0 and in the process upgraded my DB to MySQL 5.0. After the upgrade I noticed that Korean characters I used in my posts weren’t displaying correctly, but showing up as “???”.

    See:

    Korean government offers generous loan terms for poor college students

    Here’s what I have checked:
    – WordPress: Reading setting are set to “UTF-8”. I’ve also upgraded to 3.0.1 thinking it maybe a bug that they fixed.
    – MySQL: The characters are displaying correctly when I check the posts through phpMyAdmin.

    Some other hints as to what may be wrong:
    – In the admin, if I post something in Korean and save, it displays as a bunch of “???” after the save.
    – Any Korean from my twitter feed also is displaying “???” instead of Korean.

    I’m totally stumped.
    Any idea? Thanks.

Viewing 4 replies - 1 through 4 (of 4 total)
  • SimonJ

    (@simonj)


    In your wp-config, find the lines :

    define(‘DB_CHARSET’, ”);
    define(‘DB_COLLATE’, );

    Do you have any special value for these lines?

    Also, read this page in the codex :
    http://codex.wordpress.org/Editing_wp-config.php#Database_character_set

    S.

    namho

    (@namho)


    Thanks. I tried editing my config file but that doesn’t seem to work.

    SimonJ

    (@simonj)


    You didn’t answer my question… Do you have any value on these settings in wp-config?

    Try to set the default, ie to not declare any charset or collate in the wp-config.php

    Try with this settings :

    define(‘DB_CHARSET’, ”);
    define(‘DB_COLLATE’, ”);

    I had a similar problem on an installation after an upgrade to 3.0 where the latin charset was defined there… By leaving these settings empty, it was solved.

    S.

    namho

    (@namho)


    Hi Simon – thanks for the reply. I tried just as you suggested in my wp-config file:

    /** Database Charset to use in creating database tables. */
    define(‘DB_CHARSET’, ”);

    /** The Database Collate type. Don’t change this if in doubt. */
    define(‘DB_COLLATE’, ”);

    But that didn’t do anything. the Korean chars in my twitter feed are still displaying “???”.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Trouble displaying international characters after upgrade to 3.0’ is closed to new replies.