Support » Plugin: Google Analytics Dashboard for WP by ExactMetrics (formerly GADWP) » Trouble authorizing under PHP 7.1

  • Hello, Alin!
    Thank you so much for this fantastic plugin and for all your many, many updates!!

    I seem to be having trouble authorizing when the site is running under PHP 7.1. If I drop down to PHP 5.6 it seems to authorize ok.

    Here’s the error message for a failed 7.1 authorization:

    Last Error: 2017-11-09 18:49:03: Deconf_IO_Exception: The stream IO handler requires the allow_url_fopen runtime configuration to be enabled in /home/zucmanco/glenn.zucman.com/wp-content/plugins/google-analytics-dashboard-for-wp/tools/src/Deconf/IO/Stream.php:51
    Stack trace:
    #0 /home/zucmanco/glenn.zucman.com/wp-content/plugins/google-analytics-dashboard-for-wp/tools/src/Deconf/Client.php(629): Deconf_IO_Stream->__construct(Object(Deconf_Client))
    #1 /home/zucmanco/glenn.zucman.com/wp-content/plugins/google-analytics-dashboard-for-wp/tools/src/Deconf/Auth/OAuth2.php(112): Deconf_Client->getIo()
    #2 /home/zucmanco/glenn.zucman.com/wp-content/plugins/google-analytics-dashboard-for-wp/tools/src/Deconf/Client.php(128): Deconf_Auth_OAuth2->authenticate(‘4/PAPG-i2jN0DWN…’, false)
    #3 /home/zucmanco/glenn.zucman.com/wp-content/plugins/google-analytics-dashboard-for-wp/admin/settings.php(1126): Deconf_Client->authenticate(‘4/PAPG-i2jN0DWN…’)
    #4 /home/zucmanco/glenn.zucman.com/wp-includes/class-wp-hook.php(298): GADWP_Settings::general_settings(”)
    #5 /home/zucmanco/glenn.zucman.com/wp-includes/class-wp-hook.php(323): WP_Hook->apply_filters(”, Array)
    #6 /home/zucmanco/glenn.zucman.com/wp-includes/plugin.php(453): WP_Hook->do_action(Array)
    #7 /home/zucmanco/glenn.zucman.com/wp-admin/admin.php(222): do_action(‘toplevel_page_g…’)
    #8 {main}

    The page I need help with: [log in to see the link]

Viewing 1 replies (of 1 total)
Viewing 1 replies (of 1 total)
  • The topic ‘Trouble authorizing under PHP 7.1’ is closed to new replies.