Support » Plugin: Hustle - Pop-Ups, Slide-ins and Email Opt-ins » Trigger once per session not working

  • Resolved artsp

    (@artsp)


    Hi,

    I’ve set up a desktop exit-intent popup on the following page: https://skrawekpapieru.pl

    The way it’s set up is to direct people to the page with samples. The sample page is excluded in conditions, so it doesn’t show up again. However, as you navigate away from that page it starts showing up again.

    I’d like it to show only once during the user’s session. Is there any way to fix this?

    I’ve cleared cache multiples times and tested it on different devices.

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Support Predrag Dubajic WPMU DEV Support

    (@wpmudev-support1)

    Hi @artsp,

    Can you tell me which browsers and OS you were testing on?
    I just tested your site with Chrome on Windows, it opened popup on the homepage, then I clicked on it to go to samples page and from there I visited couple of different pages, including going back to homepage but none of the showed the popup for me again.

    Cheers,
    Predrag

    artsp

    (@artsp)

    Hello Predrag,

    I’ve tested in on Windows 10, Chrome, Firefox, Microsoft Edge and on an Android phone (Chrome).

    Plugin Support Nastia – WPMU DEV Support

    (@wpmudev-support9)

    Hello @artsp

    Hope you are doing well!

    I could replicate this issue on your site. Please edit the pop-up and open Display Settings.

    Under “Additional settings” choose “No longer show this message across the site” option. Right below, set Expiry Cookie to one day or more. Please see this screenshot:
    http://take.ms/Upy8K

    Please let us know how it went!

    Kind regards,
    Nastia

    artsp

    (@artsp)

    Hello Nastia,

    Thank you for the quick reply.

    I had it set this whole time and had already changed the value to as much as 30 months with no effect. Tried changing the expiry to 1 day now, but it hasn’t affected it either.

    Here’s the screenshot of my settings:
    https://www.awesomescreenshot.com/image/3979939/c21dc0af9bb7fee1d26f2ba63231e037

    Plugin Support Predrag Dubajic WPMU DEV Support

    (@wpmudev-support1)

    Hi @artsp,

    It’s strange that I couldn’t see the issue while you and Nastia could so I did bit of an extended test on my end in Chrome and Firefox.
    I check Chrome first and I couldn’t see the issue at first but it did popup up again after I have clicked on dozen pages, but only once, after that, it again didn’t show up.

    So tried in Firefox as well, and I got similar results there, after about 5 different pages the popup did show again, but it was a different page than the one it happened on with Chrome.

    This is most likely some caching issue that’s causing it so in addition to clearing the cache can you please try disabling it temporarily and see if you can replicate the issue after that?

    Cheers,
    Predrag

    Plugin Support Nastia – WPMU DEV Support

    (@wpmudev-support9)

    Hello @artsp

    Hope you are doing well!

    We’ve not heard from you in a while. I’ve marked this ticket as resolved for now, but if you need anything else at all, we’re here for you, please just reopen the ticket or create a new one.

    Have a nice day!

    Cheers,
    Nastia

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.