Support » Plugin: Boxzilla » Trigger on scroll past element malfunctioning

  • Resolved lewinontheedge

    (@lewinontheedge)


    PW to access the demo side: 123456

    Thanks for the wonderful plugin. Unfortunately, I am experiencing an issue when trying to load a box after the user scrolls past a certain element. I’m suspecting it to be a conflict with SiteOrigin Template Builder, but I was hoping that one of you might have an idea for a workaround.

    So the site has quite a complex template, and I assigned of the title elements (headline: “Trigger Trigger Trigger”) the id=”trigger”, and set the box to show when at element #trigger

    This worked fine on other pages, but for some reason, on this page, the pop-up box only shows up when the user scrolls almost to the very end of the page. I’ve tried using different elements as trigger, without success. Sometimes the behaviour changes, so that the box opens immediately when the user starts scrolling, which is also not what I want.

    Any help, hints, etc. highly appreciated!

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Danny van Kooten

    (@dvankooten)

    Hi Lewin,

    I took a look at your website and I think that this issue should be fixed by a change we made in version 3.1.19. Can you please install that update (and empty your cache) to see if that solves it?

    lewinontheedge

    (@lewinontheedge)

    Hi Danny,

    Thank you very much. Indeed it now functions properly, amazing!

    Cheers

    Plugin Contributor Lap

    (@lapzor)

    Thanks for letting us know!

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Trigger on scroll past element malfunctioning’ is closed to new replies.