Support » Plugin: The Events Calendar » Tried various versions of TEC, now fatal error activating any version

  • Resolved beatty67

    (@beatty67)


    Hi,

    We’ve been working on a demo site using a couple different versions of The Events Calendar including an older Pro version to see what we needed in terms of functionality. We also installed other helper plugins for TEC like

    • Event Tickets
    • Event Tickets Eventbrite
    • Registrations for The Events Calendar

    and realized all we needed was the free version of your plugin plus adding a button in place of a link per this post on your site: https://support.theeventscalendar.com/578190-Make-the-Event-Website-URL-a-linked-word-or-button

    So there’s your code on the functions.php file of the theme.

    Plus the tribe-events folder in the theme.
    /modules
    /meta
    details.php

    But now we can’t activate any version of the free The Events Calendar plugin at all.

    This is the error message:

    [25-Jan-2019 22:13:40 UTC] PHP Fatal error:  Uncaught Error: Class 'Tribe__Settings_Manager' not found in /.../wp-content/plugins/the-events-calendar/src/Tribe/Main.php:1910
    Stack trace:
    #0 .../wp-content/plugins/the-events-calendar/src/Tribe/Main.php(2417): Tribe__Events__Main->getRewriteSlugSingular()
    #1 .../wp-content/plugins/the-events-calendar/src/Tribe/Main.php(2948): Tribe__Events__Main::flushRewriteRules()
    #2 .../wp-includes/class-wp-hook.php(286): Tribe__Events__Main::activate(false)
    #3 .../wp-includes/class-wp-hook.php(310): WP_Hook->apply_filters('', Array)
    #4 .../wp-includes/plugin.php(453): WP_Hook->do_action(Array)
    #5 .../wp-admin/includes/plugin.php(598): do_action('activate_the-ev...', false)
    #6 in .../wp-content/plugins/the-events-calendar/src/Tribe/Main.php on line 1910
    

    The site php is running 7.0.
    We are using Divi theme which has been updated to the latest version, along with all other plugins running the latest version.

    I’d like to scrap all the tinkering and start fresh if I can’t just install the latest free version of TEC but how do I do this? Or how do I activate the latest?

    Any help on this much appreciated. Thanks!

Viewing 3 replies - 1 through 3 (of 3 total)
  • Almost forgot to mention this demo site we’re working on.

    Hey there,

    Thanks for reaching out 😄

    Sorry for the wait! We’ve been experiencing a high volume of support requests.

    It sounds like the template modifications may be triggering the fatal.

    Does switching the theme stop these errors? Or rename the tribe-events folder.

    Take care,
    Ed 🤟

    Hi Ed – It did not work.

    But we migrated everything over to a new wordpress install and that seems to have worked. Thanks!

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Tried various versions of TEC, now fatal error activating any version’ is closed to new replies.