Support » Fixing WordPress » Tried to update to 5.5 but it broke the “recent posts” home page on my site.

  • Resolved logicindustries

    (@logicindustries)


    OK, so I updated all my plugins and then updated WP to 5.5

    As soon as I did this, all the posts on my main page (which is just my “recent blog posts” page) got mashed together all on top of one another in a big jumble.

    There were still ten posts there, they were just all piled up on top of one another, all in one place.

    The rest of the site works, Woocommerce is up and the store looks correct, individual pages loaded fine, just the “recent posts” page was totally hooped.

    The theme was not changed between WP version changes, so I know it was something in the latest WP update that did it, I just have no idea what or how to fix it. I didn’t change themes to 2020 and test again, I want to use THIS theme, and I know it has to be something in the current theme that needs to be changed to work with 5.5, I just need help figuring out what has changed and where I might go look for that in the current theme.

    I’ve reverted back to last night’s Revisr commit and the site is back up and running like it should be, so I’m not hair-on-fire spun up about this, but I still need to find a fix to apply before I can update things again.

    Has something changed in the way WP handles the “recent posts” page from previous versions? There used to be a place in the dashboard somewhere to change the number of posts per row displayed on the classic blogger home page, but I cannot find it now for the life of me.

    My theme is pretty simple, but it’s not being supported by the original makers anymore (and I’ve made a few superficial modifications that I don’t want to lose anyway), so I’m on my own to figure out what has changed and how to fix it.

    Everything is stable now, but I can’t just not update for the rest of time, so I could really use some help figuring out what’s gone wrong here.

    The included link is the home page as it sets currently (IE, how it is SUPPOSED to look).

    Thank you for your time.

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Thread Starter logicindustries

    (@logicindustries)

    After poking around a little bit, it seems like maybe the masonry script is misbehaving and piling up my post blocks all in one space.

    Could this be caused by the change away from the older jquery version when they updated to 5.5?

    There are calls to jquery all over the functions.php file of my theme (as I expect there are in all of them), but perhaps the bundled scripts with my theme are expecting to encounter the older jquery version and are wigging out when they are fed through the new one?

    If this is my issue, would using the “Enable jQuery Migrate Helper” plugin help or solve it?

    I’m just grasping at straws here guys. I’m not a web programmer, I’m a machinist, so I’m working waaaaaay out on the edge of my knowledge here (past it really, if I’m being honest).

    If you made it this far, again, thank you for your time.

    Hi @logicindustries,

    It sounds like the plugin you mentioned may help with the issues you are describing. Could you give activating it a try and see if that helps?

    Thread Starter logicindustries

    (@logicindustries)

    Tried that plugin, activated both before and after updating to 5.5

    No joy in either scenario.

    I have verified that it is in fact the WP update that is breaking stuff, as the problem repeats after doing nothing but updating WP to 5.5

    Any other suggestions?

    I had the same problem on two of my blogs.

    I downloaded ‘Enable jQuery Migrate Helper’ and activated it. It fixed the problem in both cases.

    Sorry it didn’t work for @logicindustries, but my thanks to them for mentioning the plugin.

    Thread Starter logicindustries

    (@logicindustries)

    Glad it helped someone.

    Another user named rakaloah over in the Oblique theme forum (that’s the theme my child theme is based on) figured out my problem and how to fix it.

    For completeness’ sake, I’m reposting his solution here in it’s entirety:

    rakaloah said:

    WordPress 5.5 updated its bundled Masory.js from version 3.3.2 to version 4.2.2.
    Did some research on this and I found that Oblique uses ‘wp-content/themes/oblique/js/vendor/masonry-init.js’ to initialize masonry.

    In that file, the function _getColGroup:
    var colGroup = this._getColGroup( colSpan );
    was changed to _getTopColGroup in masonry version 4, so just change that line to:
    var colGroup = this._getTopColGroup( colSpan );
    and Oblique works again.

    I love this theme but it has been abandoned by its authors.
    Maybe it’s time to move on because who knows when it will break again in the future.

    I have applied his fix and verified that it works.

    Thanks to everyone who tried to help. I hope that feller’s fix helps other people with the same problem, or at least points people in the right direction.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Tried to update to 5.5 but it broke the “recent posts” home page on my site.’ is closed to new replies.