The Support Forums will be in read-only mode for a scheduled maintenance window on 01 September 2016 14:00 UTC - 20:00 UTC. More information.

[resolved] Tried to reduced database size but database is still the same size? (4 posts)

  1. matt-tyas
    Posted 4 years ago #

    Hi and thanks in advance for any help you can give me.

    I have a 100mb database limit on a site of mine. It has got up to about 66mb and I have decided to try to clear some space. I read that I needed to clear the post revisions. The blog has about 900 posts, and therefore a lot of revisions it does not need. I installed the, 'Better Delete Revisions' plugin. Ran it and it said it had removed 8000+ revisions.

    However when i log in to my host (1and1) to check the DB size it is still the same (about 66mb) although in PHPmyadmin in the WP_Posts table I can no longer see any Post_type revision. The wp_posts table is still 54mb according to PHPmyadmin however.

    I would like to be sure I have cleared some space really as I do not know what will happen when I reach the 100mb limit?!

    Thank you.

  2. Sugar Apple
    Posted 4 years ago #

    1. if your host has PHPMyAdmin, try to optimize all database table.
    2. disable or limit wordpress the revisions feature with wp-config.php
    3. usually plugins which offer LOGS eat database space (like visitor stats).

  3. matt-tyas
    Posted 4 years ago #


    Thanks for this, I did not know I needed to optimize to claim the space back. That has done it.


  4. Sugar Apple
    Posted 4 years ago #

    your welcome.

Topic Closed

This topic has been closed to new replies.

About this Topic