Support » Installing WordPress » Tried to move to different domain (using support docs), Error now

  • I think I bit off more than I can chew.

    We’ve got an old oscommerce site at, which we thought needed updating. Someone suggested that we try installing WP on a sub-directory to see if we like it, so we did. It’s at /wordpress.

    We love it, but the e-commerce plugin configurations are conflicting with our existing oscommerce settings. So someone suggested that if we own another domain (which we do), we could move it there and try out everything with modified php settings.

    I followed the steps here:

    I got to step 9 – moving the files to the new domain in my FTP client (Transmit), and I got the error:

    Could not move “index.php”. Server said: Rename/move failure: Invalid cross-device link
    Error -150: could not rename remote file

    Now I can’t access the admin panel, I can’t move the files, and I have NO IDEA what I’m doing.

    Please help!

Viewing 8 replies - 1 through 8 (of 8 total)
  • esmi


    Forum Moderator

    Error -150: could not rename remote file

    Contact your hosts. You have a server/ftp issue.

    so, just to be clear, you are trying to move the wordpress sub-directory to a separate domain? you want to keep the oscommerse or whatever it is, where ever it is… and it is working properly? (provided the wordpress is removed… )

    so, here is the solution to move the wordpress. Go to your new domain, hopefully you have a webhost for it and it has a cpanel under which you will find fantastico, using which you can install a fresh wordpress without much sweat. Please make sure to delete all files on the other domain’s host before installing a fresh wordpress installation. After that, login to the phpmyadmin of your current wordpress mysql database (sub-directory wordpress) and get the sql file. Export it to your hard disk, import it in the new phpmyadmin of the new host(for the new domain) … and it should be transferred properly…

    later on, you can get the themes and plugins from your old sub-directory of wordpress to this new installation…


    I don’t care about the oscommerce other than the fact that it’s working now, and I don’t want to disrupt that.

    So, because I can’t really test out all the ecommerce options on WP without changing the php settings, I want to move everything over to this second domain that I have.

    This second domain, however, is linked to the same MySql database as the first.

    I have gotten some help on another forum thread that has gotten me to the point where I have transferred all of WP files to the second domain. I have adjusted the wp-config to point towards the same database. Theoretically all should be well…

    But I’m finding that my images are all pointing to the old location, and I don’t know how to fix that. Also, the ecommerce plugin I was hoping to try is still not working… eShop.

    Did that make sense?
    (Thanks for the reply!)

    I probably should have done a clean new installation like you said. But I didn’t. Do you think I should wipe it and start over with a clean one?

    @dearmariana, i always like to do it a clean install, and do a fresh start… but anyways, i would suggest to do a new mysql database and import the old database and connect it to the transferred wordpress… see if that works…

    else do a fresh install, that should solve the problem… but make sure to first have a backup of your sql on your hard disk, before attempting anything..


    Hey, so I did a clean install… and maybe I’m crazy, but it doesn’t seem clean.

    Here’s what I did:
    – wiped all files from the second domain
    – did a new WP install pointing to a second, clean database on the same user account as the first…

    to be clear: My host is Aruba Italia (suck), and my login info gets me access to both domains and the MySql databases (there are 5) which are available to either of my domains. I don’t know if that matters… but in the wp-gonfig, I basically only changed the database name – user, password, and host stay the same.

    And now… things are weird.
    I’m missing random options, such as page templates that should be there with certain themes. And when I install a new plugin or theme, it gives me the ‘unpacking…’ message forever. I then have to refresh the page to find that it’s already been installed. It never gives me the ‘click here to activate now or return to the plugin page’.

    There a few other weird things. It’s running really slow. It just doesn’t seem right.

    Firstly, why not go with popular hosts, hostgator for example has a live chat option, it only takes me a few minutes to fix things through the live chat. They tell me what to do and i fix it immediately… other’s here will give you their favorite hosts, but all of those are popular hosting companies. Now, your host… i have not even heard about them…

    How did you do the clean install? if you did it manually, uploading files by FTP, i suggest you to go with the auto-install by fantastico.

    let the auto install create the My-sql database automatically… once everything is ready, just import your database…


    Hey, sorry for the delayed reply…

    Yeah, the problem is that my friend wants to use an .it domain. That’s how he got on Aruba in the first place – they’re the biggest advertisers here in Italy. They suck, but everyone here uses them for some ridiculous reason (involving Italians desires to create more paperwork for themselves). 🙂 kidding…

    Italian law prohibits the transferring of the domain to just about anywhere, and very very few hosts even allow you to register the domain. GoDaddy is one of them, so we’re giving that a try next I think.

    I’ve also been told that I can leave the .it where it is at Aruba, and have it only hosted by GoDaddy… but I don’t really understand if that involves anything extra on our part or not.

    Still learning… I realize we’re pretty far along in the process to just now be hearing about having a separate host and registrar… but there ya go. Didn’t know it was possible.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Tried to move to different domain (using support docs), Error now’ is closed to new replies.