WordPress.org

Forums

Tried to amend htaccess to improve site speed (1 post)

  1. sheikh352
    Member
    Posted 1 year ago #

    I was trying to speed up my site's loading time and I added the following code at the end of my htaccess file:

    <IfModule mod_expires.c>
    # Enable expirations
    ExpiresActive On
    # Default directive
    ExpiresDefault "access plus 1 month"
    # My favicon
    ExpiresByType image/x-icon "access plus 1 year"
    # Images
    ExpiresByType image/gif "access plus 1 month"
    ExpiresByType image/png "access plus 1 month"
    ExpiresByType image/jpg "access plus 1 month"
    ExpiresByType image/jpeg "access plus 1 month"
    # CSS
    ExpiresByType text/css "access 1 month"
    # Javascript
    ExpiresByType application/javascript "access plus 1 year"
    </IfModule>

    The problem is, when I tried opening the site, afterwards, this is what I got (and still get, despite clearing the cache:

    Warning: require(/home2/walid352/public_html/overcomingtype2diabetes.com/wp-includes/load.php) [function.require]: failed to open stream: No such file or directory in /home2/walid352/public_html/overcomingtype2diabetes.com/wp-settings.php on line 21

    Fatal error: require() [function.require]: Failed opening required '/home2/walid352/public_html/overcomingtype2diabetes.com/wp-includes/load.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home2/walid352/public_html/overcomingtype2diabetes.com/wp-settings.php on line 21

    I don't know how to fix it. Should I scrap the site, buy a new domain and start again?

    Thanks, in advance, for any help...

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags