Support » Fixing WordPress » Tried resetting permissions, now it's completely broken

  • Ok, so my server has a habit of messing up the permissions with every WP install I give it. It usually starts with not being able to upload files. Last time I did something and it got fixed, but I did not write it down… whoops.

    So this time I installed a gallery, but then I was getting the good ol “Are you sure the directory is writable?” messages when trying to upload, so I set the wp-content dir to 755. The plugin started accepting the uploads, until I clicked to Update the page, then it gave me an error with each image uploaded (Sorry, I didn’t save that text).

    At this point, I searched for the recommended permissions for WP files and directories. I put those in place, but now I get the following error when I try to access any page; admin panel or main site.

    Warning: require_once(/home/miyako/domains/ [function.require-once]: failed to open stream: Permission denied in /home/miyako/domains/ on line 29
    Fatal error: require_once() [function.require]: Failed opening required '/home/miyako/domains/' (include_path='.:/usr/local/lib/php') in /home/miyako/domains/ on line 29

    I’m going to just leave this alone until I can possibly get a hand on it… I don’t want to break it any further.

    Thanks for any help!

Viewing 2 replies - 1 through 2 (of 2 total)
  • i’d 777 it all 😛

    Well I 777’d it and it gives me access to the whole site including admin panel, but now I’m back to getting the following error:

    ‘“1_big.jpg” has failed to upload due to an error
    Unable to create directory uploads/2012/11. Is its parent directory writable by the server?’

    I just don’t know why this would be giving me this error if everything including the wp-content directory has 777 permissions…

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Tried resetting permissions, now it's completely broken’ is closed to new replies.