Support » Plugin: NextCellent Gallery - NextGEN Legacy » Tricky to add pictures to post

  • Hi there,

    I am so grateful that NextCellent is back in a new safer shape. But it is however rather tricky to add pictures to post nowadays.

    I updated the plugin half an hour ago and now I realise I have a problem.

    When writing a new post there used to be two options.

    1) The NextCellent button.
    2) Add media.

    The NextCellent button
    Nothing happens. I just get a blank pop-up where I should have options like single pic or slideshow. It is some time since this option stopped working so I am used to it.

    Add media
    The add media route worked until this update. I can browse the pictures and I can choose a picture as thumbnail but when I try to add single pic I just get a long error-text.

Viewing 6 replies - 1 through 6 (of 6 total)
  • Just noticed the same, rolling back to previous version until fixed. The error mentioned above under ‘Add media’ is as follows (when clicking to insert an image):

    Warning: preg_match() expects parameter 2 to be string, array given in /../wp-includes/formatting.php on line 1515
    
    Warning: strip_tags() expects parameter 1 to be string, array given in /../wp-includes/formatting.php on line 1967
    
    Warning: array_keys() expects parameter 1 to be array, string given in /../wp-content/plugins/nextcellent-gallery-nextgen-legacy/admin/media-upload.php on line 25
    
    Warning: array_shift() expects parameter 1 to be array, null given in /../wp-content/plugins/nextcellent-gallery-nextgen-legacy/admin/media-upload.php on line 26
    
    Fatal error: Uncaught Error: Call to a member function get_thumbcode() on boolean in /../wp-content/plugins/nextcellent-gallery-nextgen-legacy/admin/media-upload.php:34 Stack trace: #0 /../wp-includes/class-wp-hook.php(298): media_upload_nextgen('') #1 /../wp-includes/class-wp-hook.php(323): WP_Hook->apply_filters('', Array) #2 /../wp-includes/plugin.php(453): WP_Hook->do_action(Array) #3 /../wp-admin/media-upload.php(110): do_action('media_upload_ne...') #4 {main} thrown in /../wp-content/plugins/nextcellent-gallery-nextgen-legacy/admin/media-upload.php on line 34
    Plugin Author WPReady

    (@wpready)

    Thanks for posting this. I’ve been working to fix the issues as soon as possible.

    Hi WPReady, any eta on your next bug fix release? Would really like to upgrade but not much use if I can’t add images to posts.

    seedy

    (@seedy)

    I am getting a blank white dialogue box when trying to add photos since I tried 1.9.32 and it hasn’t worked since I reverted. Happening with 1.9.30 as well.

    Any suggestions?

    Hi!

    Yes, also blank popup on all my installations when opening in editor.

    WordPress current version
    All Plugins for testing deactivated
    Noting different by go ging back to old versions.

    Thanks for any help.

    Best Regards

    Hi @ispreview, @timbob and @seedy

    Appologies that I am writing almost the same reply in several places. I went backward in the forum.

    I’ve realised that short codes still work. I found some at @wpready web page. Some worked and some didn’t.

    The simple one like this: [singlepic id=2992 float=none] works. Just change the number to whatever picture you want to include.

    (Adding Watermark, changing thumbnail sieze and some other things doesn’t work)

    Hope this will help someone.

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.