Support » Themes and Templates » Travelogue theme: possible bug solution

  • Resolved somatix


    Hi guys,

    I am going to travel around the world in a few days and therefore I will have my own blog using Word Press.
    I installed Word Press on my computer and I found a nice related theme for my journey: Travelogue made by user uplink. I changed some settings and images of this theme, to give it my own style. Everything went well and my site was running perfectly fine.
    A couple of days ago I registered my own domain for my blog. I installed Word Press and I (immediately) installed/activated the travelogue theme. I went to my homepage, but ending up in a page with a HTTP 500 Internal Server error. Using a different theme didn’t give any problems, so it has to do with the Travelogue theme.
    I searched on google and on this forum for a possible solution. A proposed solution was to adjust the php_value memory_limit as described as solution in (press the ‘here’ link). The solution also described that my hosting provider may also limit this php memory allocation cache. Therefore, I contacted my hosting provider. Also note, I could not look into my webserver log.
    In respond, my hosting provider turned on error reporting. My Word Press with Travelogue blog returned the following error:

    ‘WordPress database error
    Unknown column ‘link_category’ in ‘order clause’ for query SELECT * , IF (DATE_ADD(link_updated, INTERVAL 120 MINUTE) >= NOW(), 1,0) as recently_updated , UNIX_TIMESTAMP(link_updated) AS link_updated_f FROM wp_links WHERE 1=1 AND link_visible = ‘Y’ ORDER BY link_category ASC made by require, require_once, include, get_sidebar, locate_template, load_template, require_once, get_links, get_bookmarks’

    Analyzing this error revealed that it is triggered by the function get_bookmarks (wp-includes\bookmark.php). I didn’t use this php file, but I realized that maybe a widget may use it. Ironically, I didn’t use any widget, but then somehow this code is triggered by a default widget. I activated one widget and my problem was solved.

    So by activating a widget, the code in bookmark.php is bypassed and my problem is solved.

    I hope some of you guys may see this post to be useful.



Viewing 2 replies - 1 through 2 (of 2 total)
  • Stephan,

    Thanks for noticing that and for your very well-done investigative work. I hadn’t heard about this, but after reading your post I took a look at the sidebar.php file and realized that I hadn’t replaced an old, deprecated function call to grab the links with the newer version of the method. That is probably what was causing the root of the issue.

    I’ll patch that up and put out a fix on the theme. Thanks, and have fun with your travels!

    Joshua – Travelogue Creator

    I’ve uploaded a new version of the theme to the WordPress repository, but I have to wait for it to be approved.

    In the meantime, if there is anyone else with this issue, here’s how to quickly fix it. Find line 51 in sidebar.php that says:

    <?php get_links('-1', '

  • ', '
  • ', ' ', 0, 'category', 0); ?>

    and replace it with:

    <?php wp_list_bookmarks('title_li=&categorize=0'); ?>

    The new version of the theme has a couple other fixes as well, but this is the patch for this particular bug.


Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Travelogue theme: possible bug solution’ is closed to new replies.