Support » Plugins » Transposh plugin getting caught in redirect loop

  • Hello There,

    First of all Transposh is a great plugin! It works fantastic and solves some big issues that other plugins have left.

    I have a blog that has become quite large (over 1000 users, 5000 participants) and it is across many countries and its content is international.

    My website does have a problem when activating this plugin because it gets caught in a redirect loop after an hour or so of activity. I can fix this problem temporarily by clearing the caches ((Purges everything: The page-cache, the CDN cache, and the object cache)

    However within a few hours the site will get caught in a redirect loop again and I have to flush it once more.

    I have read the FAQ pages on the plugin site and found the threads relative to it but the fixes to the plugins/themes don’t apply to my situation.

    Here are a list of my plugins

    better menu widget
    cleantalk spam protect
    comment disable master
    cudazi scroll to top
    facebook featured image and open graph meta tags
    gravity forms
    gravity forms – multi-lingual
    gravityforms aweber
    gravityforms user registration
    lightbox pop – not activated
    page links to
    sitepress multilingual cms – not activated
    user avatar
    wordpress importer
    youtube embed plus
    WPML – old translation program (has been deactivated)

    I also have set up a mirror site in a staging area that is non-cached according to my host. I have noticed that the redirect loop does not happen there. (you can login with the same details from above.

    Additionally I have a dedicated WordPress Host called WP Engine.

    They have told me that in order to solve the problem once I have spoke with the developer that they can adjust their server settings to best suit the site and plugin configuration.

    I would really appreciate some help with this as I have really tried everything within my own abilities.

    Once again this is a great plugin!

Viewing 4 replies - 1 through 4 (of 4 total)
  • esmi


    Forum Moderator

    First, identify exactly which plugin you are using and then post in that plugin’s dedicated forum via its page in the Plugin Repository.


    I have the exact same problem with Transposh but not on such a frequent basis. I have a website and also use WP Engine. I will post on Transposh’s plugin Support but wanted to let you know you are not alone. It might have something to do with the language translations? because the first time it happens for me I see another language as a subdirectory and then it gets stuck. The problem goes away if I add a question mark after the website (ie. but WP Engine has no way of setting that as a default.


    I have just migrated a website to WPEngine and have the exact same error you have. I get a redirect loop caused by Transposh showing another language as a subdirectory.

    Did you find a fix for this?


    I loaded “Infinity Cache” as a plugin in and that did the trick. I purged the cache once and since then have not had the issue come up every again.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Transposh plugin getting caught in redirect loop’ is closed to new replies.