Support » Plugin: Transposh WordPress Translation » Transposh and xmlrpc

  • Hello, I have been a user of this plugin for a long time. I need some answers: first I want to know if Transposh uses or needs xmlrpc.php enabled to work properly. I had to disable xmlrpc from one of my sites for security reasons. I do not know if one thing has to do with another, but for some time when I’m going to publish an article the translation is interrupted and I have to press the update button to continue translating. I do not know if this has gone through the latest updates of the plugin or because you disable xmlrpc .. any suggestions?

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Ofer Wald



    xmlrpc.php is not used. transposh uses admin-ajax.php

    Thanks for the information, that leaves me more calm, however I need to find out what is interfering with the proper functioning of this plugin. This could be related to Heartbeat ?, if I disable or limit the use of Heartbeat, can this interfere with the proper performance of Transposh? Can this be the cause of translation interruptions?

    Plugin Author Ofer Wald



    I have to admin I am not even sure what heartbeat is, so it is probably not related, but since I don’t really know – It might…

    You are not providing enough information about what is wrong, I can’t really tell.

    Here is something about WordPress Heartbeat

    I will try to explain to you again what is wrong: When making or updating a publication Transposh starts with the translation, but then it stops and I have to click again on the update or publish button to continue with the translation, this last step I must do it two or three times so that the publication is completely transduced or so that Transposh indicates to me that there is nothing to translate. I am trying to investigate the cause of this behavior to try to solve it.

    Plugin Author Ofer Wald



    I don’t think it has anything to do with this, you will need to inspect the calls that are going on, sometimes the translation proxy might stop responding (your site might get temporary black listed on the translation engine), You may try switching engines, and maybe enable transposh debug logging to find out what is going on.

    In Debug settings it says this:
    This is extremely dangerous, will break your current translations, and could cause severe hickups, only if you really know what you are doing.

    This scares me a bit, I do not know why enabling debug logging could break the translations, but I need to resolve this. Should I create this file manually (error_log or debug_log or something similar) in the plugin folder so that the debug information is saved there or the plugin will create this file automatically ?, Once activated and configured these options where I will see the information thrown on possible errors? … excuse my ignorance.

    Plugin Author Ofer Wald


    It will probably not really cause severe hiccups, but logging takes its toll on performance and might divulge information that you might not want to share to people with access to those logs. (not that I think there is such information, but better safe than sorry)

    But yes, the file should be automatically created.

    Good luck

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Transposh and xmlrpc’ is closed to new replies.