WordPress.org

Support

Support » Plugins and Hacks » Transposh WordPress Translation » Transposh 0.94 & Firefox 26

Transposh 0.94 & Firefox 26

  • Hello,
    I noticed a problem using Transposh with Firefox (I’m using the latest version of FF and Transposh).
    When a page is untranslated and I visit it with a browser different from Firefox (Internet Explorer, Chrome), it all works perfectly. The text is translated on-the-fly into the desired language and memorized into the database. Then, when I visit it with Firefox, it is correctly displayed in the translated language.

    The problem arises when an untranslated page is loaded for the first time with Firefox. The translation never takes place. I tried to empty the cache, and even to disable both disk and memory cache from “about:config”.
    No error is shown in the Console window of FireBug. I tried also disabling all FF addons (safe mode), but nothing happens.

    How can I fix it? Thank you very much.

    http://wordpress.org/plugins/transposh-translation-filter-for-wordpress/

Viewing 2 replies - 1 through 2 (of 2 total)
  • I also completely removed the Supercache plugin, I thought it was solved because the translation worked for some minutes. Then it stopped again.

    Translation on Chrome is almost real-time, in Firefox there is no sign of activity. 🙁

    A little update: I replaced the minified version of lazy.js with the standard version (direct link), then I commented out lines 172-186, replacing them with “callback();“. It seems to work. I think lazy.js was using an hack for Firefox in order to know if the css loading was complete, but this hack does not work anymore on FF 26. These are the lines I commented out in lazy.js:

    var hostname = location.hostname.replace('www.',''),
                    hrefHostname = /http:/.test(href) ? /^(\w+:)?\/\/([^\/?#]+)/.exec( href )[2] : hostname;
                hostname != hrefHostname && $.browser.mozilla ?
                    callback()
                    :
                    //stylesheet is from the same domain or it is not firefox
                    (function(){
                        try {
                            link.sheet.cssRules;
                        } catch (e) {
                            cssTimeout = setTimeout(arguments.callee, 20);
                            return;
                        };
                        callback();
                    })();

    I replaced them just with
    callback();

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Transposh 0.94 & Firefox 26’ is closed to new replies.
Skip to toolbar