Support » Fixing WordPress » transport error – HTTP status code was not 200

  • OK – I have tried the few solutions I could find to this problem, with no luck. Using FeedWordPress, which had previosuly been working fine, suddenly I get this error when attempting to update the syndicated content:

    update-feeds: instruct FeedWordPress to look for new syndicated content
    Sending ping to <;…

    The XML-RPC ping failed (local): transport error – HTTP status code was not 200

    I am beginning to suspect this is something I might have to contact my host admin for – perhpas some kind of change they made to something (all that is well beyond, so I have no idea what it would be). The main reason I suspect this is because I was able to put all the previous files back on the server, to replicate the exact same configuration, on my end, of the site when it was working. Could it have anything at all to do with the fact that we – meaning the people who use my host – share an IP address? Maybe that is a stupid question, I just don’t know. Or could this be related to an Apache handler problem? Any ideas would be much appreciated – I took everything off of my server and was going to rebuild the site entirely, but have been stuck trying to get the syndicated content working again, and it is driving me crazy!

Viewing 3 replies - 1 through 3 (of 3 total)
  • Oh – I also should add that I am running the latest version of WordPress, but I have tried it with old versions as well, with no change. Like I said, I even put the exact same files I previously had on the server when everything did work, and it didn’t fix it – which is why i suspect it is something either the host has changed, or maybe that I need to add an Apache handler.

    I’m having the same trouble. I thought I fixed it on one site by simple changing the permissions on xmlrpc.php and update-feeds.php to 755. However, I encountered the same problem again on another server, and changing permissions doesn’t help any more.

    Did you fix yours, and how?

    Thanks so much in advance!

    Hey all,

    The “not 200” error code is one of a couple “mystery errors” that versions of FeedWordPress up through 0.96 might return due to any number of error conditions. The latest version of FeedWordPress (0.97, available at features a pretty fundamental overhaul to update-feeds.php, which may solve the problem you are having entirely; and if it does not solve the problem, it should, at least, make it much easier to diagnose, and either fix or accurately report, the problem.

    Hope this helps!

    –Charles Johnson

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘transport error – HTTP status code was not 200’ is closed to new replies.