Support » Theme: Astra » Transparent Header – Submenu background turns into white

  • Resolved LuWi

    (@luwiserjeus)


    I’ve noticed that many of us experience the same problem. Although a number of issues are now listed as “resolved”, the problem has not actually been addressed. If the solution is that we have to manipulate CSS ourselves, that seems more a work around the problem than a solution. To be clear: since version 3.1.0 (and certainly also in 3.1.1) every submenu has appeared in my transparent header with a white background (and since I also have a white font, you don’t see anything). The settings in the transparent header submenu are indeed set to transparent, it has also worked until the update. I hope that real work will be done on this soon. Thank you.

    The page I need help with: [log in to see the link]

Viewing 8 replies - 1 through 8 (of 8 total)
  • Thread Starter LuWi

    (@luwiserjeus)

    I restored Astra 3.0.3 from backup in order to continue, but hopefully this bug is solved very soon, so I can update again in order to keep my website aligned with the latest version.

    Hello @luwiserjeus

    Sorry for any inconvenience!

    We have fixed the issue and released an update with the v3.1.2, please update and let us know if it helps. 🙂

    Looking forward to hearing from you.

    Thread Starter LuWi

    (@luwiserjeus)

    Hello @brainstormteam

    The update makes me changing the background color back again however I can never revert it to transparent. Also, when I choose any color there is always a kind of “fog”-layer above. e.g. if I choose red the background appears to be a kind of soft-red (more pinky). If I “clear” the setting: everything turns into white (again).

    So, it has improved but it is still not fixed.

    Thanks for solving the case.

    Same here – it is not white anymore but it is still NOT transparent.

    Hi @luwiserjeus / @smochen ,

    Have you checked the Transparency setting of the submenu under the Transparent Header section? Please refer to this screenshot.

    Let us know how you go.

    Kind regards,
    Herman 🙂

    Thread Starter LuWi

    (@luwiserjeus)

    Hi Herman,

    Yes, indeed, I did.

    While receiving your update I was suggested to check if the new header/footer builder was activated. And indeed, it wasn’t activated yet as I upgraded from 2.6 to 3.0 without knowing/understanding this has to be done actively.

    With the help of the video: https://wpastra.com/docs/create-header-with-header-builder/ I was able to fix.

    Thanks a lot for your concern and your help.
    Kind regards.
    Luc

    @luwiserjeus – That was the solution.

    You have to activate “New Header/Footer Builder”. I didn’t know this as well.

    Now it works.

    That’s perfect, @smochen / @luwiserjeus

    Glad to hear that the issue has been resolved on your end! 🙂

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.