Support » Fixing WordPress » ‘Translations’ not updating

  • Hi!

    Currently running WP 5.7 on a bilingual site (through WPML). All plugins up to date.

    In the ‘WordPress Updates’ section, it says:
    ‘New translations are available.’

    I click on ‘Update Translations’ & got:
    ‘Updating translations for Elementor Pro (en_GB)…
    Translation updated successfully.
    Updating translations for Elementor Pro (ro_RO)…
    Translation updated successfully.
    Go to WordPress Updates page’

    The last line above is a link. Then when I click on it, it starts all over, with the ‘New translations are available.’ message. It has been doing this for the last 3 or 4 days.

    What do I do, and where?

    Thank you!

    The page I need help with: [log in to see the link]

Viewing 12 replies - 1 through 12 (of 12 total)
  • Thread Starter sambio

    (@sambio)

    Seems the problem is solved for now.

    I disabled Elementor & reactivated. Not sure why and how it happened, but it is all good.

    I’m having exactly the same problem with the German translation of Elementor Pro…

    I’ll try doing as you did. Thanks for posting!

    Arghh… I disabled Elementor (and Elementor Pro) just like you said, but after reactivation the problem persists!

    The ‘New translations are available.’ link keeps coming back over and over.

    Looks like this topic is not “Resolved” at all…

    Or did you update the translation WHILE Elementor (Pro) was disabled? I had tried again after reactivation.

    Yeah… When you update the translation WHILE Elementor (Pro) is DEACTIVATED the link goes away (even after reactivation).

    So this topic IS actually resolved. Thanks again!

    I’m having the same problem, but deactivating Elementor & Pro then updating translations doesn’t seem to fix the issue. I’ve tried a combination of deactivating, updating and reactivating in different orders. It’s worked on some sites but not all.

    Hi All – I’m having the same problem. I deactivated Elementor Pro and the translation disappeared. When I re-activated the plugin, awhile later the translation comes back !!

    Thread Starter sambio

    (@sambio)

    Yep, still having the same issue. Deactivating Elementor Pro & updating translations only solves the issue temporarily, then the issue reappears. I contacted both WMPL & Elementor and they each blamed each other. I was also told it might be a WP issue, so the next update might fix it.

    As of now, no real solution. Will keep waiting.

    PS As the OP, I have just changed the status of the topic to “not resolved”, so hopefully somebody will see this & wait.

    I’ve the same issue but I haven’t installed the WPML plugin, I’ve just installed WordPress in spanish and then installed Elementor and Elementor Pro.

    So, maybe WPML is not the culprit here and maybe it’s and Elementor and/or Worpdress problem.

    After reactivating Elementor and Elementor Pro the issue appears again.

    I don’t think, either, that WPML is responsible for this behaviour. I manage several websites that don’t have WPML installed and the Elementor Pro translation update issue is there anyway.

    I don’t even know if the Elementor Pro translations ARE actually updated but not registered eventually or if the update processs itself is faulty (although there’s always that message that it has been successful).

    Thread Starter sambio

    (@sambio)

    I think it is a WP issue & not a WPML one.

    I think we should all wait for the next WP update & that might fix the issue.

    It would be also nice if WP would respond to this thread – the issue is marked, after all, as “not resolved”.

    Hi guys, it’s started happening for me today as well. I’m running a site in three languages and I keep seeing the update available, on the updates page “New translations are available” click on that, when update has finished it says that Elementor Pro EN_GB has been updated. Minutes later, updates are available.

    Thread Starter sambio

    (@sambio)

    Yep, that’s the one. Welcome to the club 😉

Viewing 12 replies - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.