Support » Plugin: Email Subscribers & Newsletters » Translations not showing

  • Resolved antoine69

    (@antoine69)


    Hi,
    I’ve downloaded the .pot file and generated my french translations .po and .mo files.
    I’ve named them email-subscribers-fr_FR.po and .mo but the translations are not showing on the front-office.

    I want, at least, the word of the button “Subscribe”, the placeholders of the 2 fields “Enter Name” , “Email address” and the words “Name” and “Email *” both just before their respective fields, to be translated.

    Could you check if theses words are in the .pot file because I don’t think they are and also if the names of the files .mo and .po are OK (see above).

    Thanks

Viewing 9 replies - 1 through 9 (of 9 total)
  • I had the same problem for german. Looking into source code showed me, that these words are still “hard coded”. So I decided to edit them manually.

    Check the file here https://plugins.trac.wordpress.org/browser/email-subscribers/trunk/public/partials/class-es-shortcode.php

    Lines 136-138 / 167 / 189.

    However, you had to do the edit every time after an update, since the file will be overwritten. Do not store the file and replace it after the update, otherwise you’d miss code changes.

    Currently localization does not work. It is a pitty!!!

    • This reply was modified 8 months, 1 week ago by  olivermerk.

    @olivermerk

    The file you talk about is not ready for translation as I can see, you’re right.
    So some words are missing in the /languages/email-subscribers.pot file .
    Since the .pot file exists it should contain all the words of the plugin front and back-office. This file is not uptodate but I think they will work it out soon.

    • This reply was modified 8 months, 1 week ago by  antoine69.
    • This reply was modified 8 months, 1 week ago by  antoine69.

    At least you can use these terms:

    $name_label = ( 'yes' === $required_name ) ? __( 'Name *', 'email-subscribers' ) : __( 'Name', 'email-subscribers' );

    $email_html = '<div class="es-field-wrap"><label>' . __( 'Email *', 'email-subscribers' ) . '<input class="es_required_field" type="email" name="email" value="" placeholder="Email Address" required/></label></div>';

    Note, there are two alternatives for “Name” and “Name *”.

    However, the placeholder are missing for translation. Maybe they will make them user configurable in the Settings section. We will see…

    • This reply was modified 8 months, 1 week ago by  olivermerk.
    Plugin Contributor Malay Ladu

    (@malayladu)

    @antoine69 @olivermerk

    Noted.

    Will be fixed in ES 4.0.5.

    antoine69

    (@antoine69)

    Hi,
    I now run the plugin v4.0.6 and still the translations are not showing.
    I renamed the 2 .mo and .po files email-subscribers-fr_FR ;
    Thanks
    Patrick

    antoine69

    (@antoine69)

    Hi
    It seems the v4.0.7 still doesn’t solve the problem ?
    Thanks

    • This reply was modified 8 months ago by  antoine69.
    antoine69

    (@antoine69)

    Hi,
    In v4.0.8 I cannot set up a new translations in my language because PoEdit detects somme duplicate sentences or lines.
    Could you check this please ?
    Thanks

    Hi,
    I’ve updated the plugin with v4.0.10 and still the translatiosn do not show.
    Anyone encouter this problem with your language ?
    Thanks

    Plugin Contributor Malay Ladu

    (@malayladu)

    @antoine69

    Just want to update you that translations are now loading from WordPress

    So, it might possible that translation is not available in your language yet.

    At this moment, I can see that Emails Subscribers is translated 100% into German (Thanks to @docolli)

    It would be great if you can go to WordPress and translate Email Subscribers into your language.

    Hope that helps.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Translations not showing’ is closed to new replies.