Support » Plugin: WPCasa » Translations & Additional Fields

  • Hi, have one question:

    Have WP Casa & Polylang (both installed + WPCasa Polylang) – I’m using 3 languages – german, english and spanish: when I display the search using shortcode, there are some strings not translated, like “Keyword or Listing ID”, “Type”, “Location”.
    (even if the po files exist)

    The same happens with additional fields like “Plot Size”, it stays in the default WordPress language , even if it looks, it should be loaded from po file (Plot Size —> Terreno in spanish, Grundstuck in German)

    any idea?
    Thanx in advance

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author WPSight

    (@wpsight)

    Hello,

    thank you for your message.

    Strings like “Keyword or Listing ID” should actually get translated via MO/PO Files. For this you could use a plugin such as Loco Translate for example.

    Strings such as “Plot Size” or other details can be changed from within the WPCasa Settings (WP-Admin > WPCasa > Settings > Listing Details) and from the Polylang String Translation.

    Let me know if there is anything else I can do for you.

    All the best

    Thanx for your quick response.
    —-> It looks like the problem is with “Keyword or Listing ID” only ?

    I have already Loco Translate installed but I don´t need – for now – to change anything in the transation files, I want just to load them 🙂

    And the translations already exist , for example for german:

    wp-content/plugins/wpcasa/languages/wpcasa-de_DE.mo
    wp-content/plugins/wpcasa/languages/wpcasa-de_DE.po

    but they don´t get loaded…..

    Plugin Author WPSight

    (@wpsight)

    Hello,

    to load the translation files you actually would need to use WordPress in your language then. You can change the language settings from WP-Admin > Settings > General. There you can simply choose the language you want to use.

    In case you’re using WordPress with a multilingual solution (such as Polylang or WPML) then again there is the default language in WordPress and the multilingual plugin should then take care of the rest and switch the language accordingly.

    Let me know if anything remains unclear.

    All the best

    heneart

    (@heneart)

    Hi,

    i’m using Polylang…
    so far everything works fine, the translation files are present, but…
    the searchbox field “Keyword or listing ID” shows always in english, even if changing the frontpage to german or spanish.

    I found a “kid of” solution for this strenge behaviour, using this filter:

    add_filter( ‘wpsight_get_search_fields’, ‘wpsight_get_search_fields_keyword_placeholder’ );
    function wpsight_get_search_fields_keyword_placeholder( $fields ) {

    $fields[‘keyword’][‘label’] = __( ‘TYPE HERE WHAT YOU WANT’, ‘wpcasa’ ) . ‘…’;

    return $fields;

    }

    , and then “TYPE HERE WHAT YOU WANT” can be translated properly through Polylang strings….

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.