Support » Plugin: On This Day (by Room 34) » Translations

  • Robert

    (@metbril)


    My blog is in Dutch (nl-NL). I noticed that the dates in the widget are printed in English and would like these in Dutch (actually, follow the default WordPress language setting). Would you consider modifying this?

    And I would also like to be able to translate the rest of the strings in the plugin. But the Translate page says the plugin is not prepared for translations. Would you also consider adding support for i18n?

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author room34

    (@room34)

    Can you share a link to the page where you’re displaying the plugin? I would have thought the dates would be picking up the WordPress translations automatically. I might just need to change which function I’m using to display them.

    As far as translating the rest of the text goes, I’ve started the process of adding i18n support. I’d like to add it sooner rather than later, but realistically I probably won’t be able to get to it for at least a couple of months.

    Thread Starter Robert

    (@metbril)

    You can have a look at the footer of any of my pages at https://robertvanbregt.nl/

    Plugin Author room34

    (@room34)

    Thanks… I will try to get an update that fixes the dates (based on the WordPress settings) rolled out within the next 24 hours. Full i18n support will take more time.

    Plugin Author room34

    (@room34)

    OK, I’ve confirmed that switching from a couple of spots where I was using the PHP date() function to the WordPress wp_date() function is automatically translating the month names in the dates. Version 2.4.0 with this change will be available shortly.

    I will prioritize getting full i18n support implemented in the next update.

    Plugin Author room34

    (@room34)

    One more update on this… I’m not sure when I’ll be able to get to the full i18n support, but I was able to make one small change that should help in the meantime.

    Up to now, the one phrase, “See all…” was the only text displayed on the front end that was not editable in the widget configuration. I’ve made this editable text, so you can change it to whatever you like.

    The admin interface is all still in English at this point, of course, but now there is no need for anything on the front end to display in English. (This change is in version 2.4.1.)

    • This reply was modified 2 years ago by room34.
    Thread Starter Robert

    (@metbril)

    Thanks for the quick response. Looking forward to the update.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Translations’ is closed to new replies.