• Resolved Patrice

    (@patricevigier)


    Hello,

    With Polylang I could translate, in French, most of the fields excepted from the pop up windows that you get to select which type of cookie you authorize. (from the button Cookie settings)

    How can we add text to translate this popup window in Polylang so it can be relevant for many language ?

    WP 4.9.15 and WP 5.6
    PHP 7.3

    Thank you
    Patrice

    The page I need help with: [log in to see the link]

Viewing 8 replies - 1 through 8 (of 8 total)
  • Thread Starter Patrice

    (@patricevigier)

    I could have access to the translation of Non-necessary after going to the y Non-necessary Cookie Settings and save it again

    But the button Save and Accept is still not available for translation

    Plugin Author webtoffee

    (@webtoffee)

    Hi @patricevigier,

    Since it is not a user-editable string, it is translated via the plugin directly. The translations are already added here. To get the already translated strings, please deactivate and delete the plugin once and reinstall. All settings and customization will remain intact.

    Thread Starter Patrice

    (@patricevigier)

    Hello,
    Thank you for your answer
    On my WP 4.9.15 I did uninstall, delete and reinstall but I still have
    the button “Save & Accept”
    Show more
    Always enable
    etc.
    in English instead of French

    On my WP 5.6 it was a fresh install (new site) and the same behavior.

    I confirm that the translation is in the cookie-law-info-fr_FR.po file, so is this a conflict with Polylang?
    Or is it because the site is English by default?

    Sincerely

    • This reply was modified 1 year, 8 months ago by Patrice.
    Thread Starter Patrice

    (@patricevigier)

    Also [user_consent_state] is not translated and display, in french,
    Your current state: Consent accepted. Manage your consent.

    • This reply was modified 1 year, 8 months ago by Patrice.
    Plugin Author webtoffee

    (@webtoffee)

    Hi @patricevigier,

    The plugin loads the translation based on user profile language or site default language. Try switching your user profile language to French.

    Thread Starter Patrice

    (@patricevigier)

    Hello @webtoffee,
    Thank you for your answer.

    Your suggestion do not work
    I maintain WP with Firefox, so when I look at my site on Firefox, the site act like I’m logged in and my WP interface is in English.

    But I checked on Chrome, so I’m not logged and the Chrome default language is French but I still have what I pointed out in English.
    Sincerely

    Plugin Author webtoffee

    (@webtoffee)

    Hi @patricevigier,

    We are unsure why it does not work for you but the strings is translated in the plugin. You can check here.

    Thread Starter Patrice

    (@patricevigier)

    @webtoffee
    Thank you for your answer.
    I know it is translated but this does not help me as it does not translate in the front end.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Translation with Polylang’ is closed to new replies.