Support » Plugin: Profile Builder - User Profile & User Registration Forms » Translation problem with PageBuilder

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author Gabriel Berzescu

    (@gabrielberzescu)

    Hello Harley,

    Do any strings show up as translated? Or noting at all?

    Have you updated from the last .pot file? If not, please do so and try again.

    With the best of regards,
    Gabriel

    Thread Starter Harley Leung

    (@suongliang)

    Hello Gabriel,
    Currently there’s only term ‘Password’ is translated ( as it was approved before ? ),
    the other terms that I added the translation are not working.
    F.e :
    + Login form
    You are currently logged in as %s.
    + Registeration form :
    CONTACT INFO
    ABOUT YOURSELF
    First Name
    Last Name
    Nickname

    I’ve also updated from the last .po and .mo files

    Plugin Author Gabriel Berzescu

    (@gabrielberzescu)

    Hello Harley,

    If you remove the files altogether, does the term ‘Password’ remain translated, or does it revert to English?

    We need to determine if the translation file is loading or not.

    Also, I did not say to update from the last .po file, but to update from our latest .pot file:

    If you are using Poedit, when you are editing the .po file, in the menu, click Catalog and then Update from POT file, and select our latest .pot file, found in profile-builder/translation

    Thread Starter Harley Leung

    (@suongliang)

    If you remove the files altogether, does the term ‘Password’ remain translated, or does it revert to English?

    Dear Gabriel, after removing files, the term Password remain translated.
    I just updated from your last POT file, it throws out some warnings and I fixed that, looks like the translation files are not firing, I’ll try to figure out

    Plugin Author Gabriel Berzescu

    (@gabrielberzescu)

    If you try other languages, like French or something, do you see any string translated?

    Thread Starter Harley Leung

    (@suongliang)

    Good day Gabriel, sorry for the late reply.
    I have added German (DEUSTCH) to test the language pack, looks like the login page is fully translated in german but registeration page is not.
    You can see the captured screen here.

    https://drive.google.com/drive/folders/1HSFGuTpyeClzWsyNwelxZhp9R0cUBMlg?usp=sharing
    (folder de – German, vi – Vietnamese)

    • This reply was modified 2 years, 10 months ago by Harley Leung.
    Thread Starter Harley Leung

    (@suongliang)

    Ah, I found the solution, currently the website is using QTranslate so I guess I have to change the field title in the Profile builder setting page based on that syntax :
    Solution found
    This help fixing on the registeration form, however this is not 100% resolved for the notifications from Profile Builder

    • This reply was modified 2 years, 10 months ago by Harley Leung.
    Plugin Author Gabriel Berzescu

    (@gabrielberzescu)

    Hello Harley,

    I’m glad to hear that the problem is partially solved.

    I think that maybe if you use those translation tags with our Labels Edit add-on, you might get it to work with qTranslate.

    If not, then perhaps try another multilingual plugin, such as our TranslatePress.

    Cheers,
    Gabriel

    Plugin Author Gabriel Berzescu

    (@gabrielberzescu)

    But before anything, ploase do this conflict test first:

    *Briefly* disable all other plugins and enable a default WordPress theme, such as Twenty Seventeen.

    Does the Vietnamese translation work now? What about the German translation?

    Best regards,

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Translation problem with PageBuilder’ is closed to new replies.