Support » Plugin: wpForo Forum » Translation problem

  • Resolved odedta

    (@odedta)


    Hello, I am using Loco Translate and the latest release of both plugin and translations.
    For some reason some of the words do not appear in Hebrew even though they are translated. View attached:
    Frontend | Backend

    In addition, I don’t understand how to change the title (<title></title> for a forum.

    This is the page: https://delab.odedta.com/forum

    Thanks

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Support gVectors Support

    (@gvectorssupport)

    Hi @odedta,

    Thank you for using wpForo and for contacting us.

    Please read this support topic. Here is explained how to manage and translate the forum menu:

    https://wpforo.com/community/faq/how-to-translate-forum-menu/

    In addition, I don’t understand how to change the title (<title></title> for a forum.

    You’re probably using a SEO plugin. Other SEO plugins have conflicts with wpForo forum plugin. Are you using any plugins?

    odedta

    (@odedta)

    Hello,
    Thanks for letting me know it’s in the menus section.
    As for the SEO, i’m using RankMath.

    odedta

    (@odedta)

    In addition please let me know how to translate the word Share. View attached:
    Screenshot-5
    Screenshot-6

    • This reply was modified 5 months ago by odedta.
    Plugin Support gVectors Support

    (@gvectorssupport)

    Hi @odedta,

    In addition please let me know how to translate the word Share. View attached

    All wpForo frontend phrases are located in The Dashboard > Forums > Phrases admin page. If you can’t find some phrase you can add it using [Add new] button.

    More info here: https://wpforo.com/docs/root/translation/quick-translation-phrases/

    As for the SEO, i’m using RankMath.

    For wpForo, the best option is the built-in wpForo SEO system. If it is already turned on it works fine. So there is no need to use additional SEO plugins for wpForo pages.

    Please read this support topic:
    https://wpforo.com/community/general-discussions/how-do-i-integrate-rank-math-with-wpforo/

    odedta

    (@odedta)

    Hello,
    I am very happy with your plugin, however, there is 1 thing I cannot seem to figure out.
    Look at this page: https://delab.odedta.com/forum/
    If you view the source you would see that <title></title> tags are not present, is this by default? is this caused by some conflict?
    Screenshot-1
    Thanks

    Plugin Support gVectors Support

    (@gvectorssupport)

    Thank you @odedta,

    If you view the source you would see that <title></title> tags are not present, is this by default? is this caused by some conflict?

    That’s why I’ve asked you about the SEO plugin you’re using. Please deactivate the RankMath plugin, delete all caches and check again.

    odedta

    (@odedta)

    What good is that going to do? If i’m forced to decide between an SEO plugin and wpForo I choose SEO plugin.
    You really don’t have solution for this!?

    Plugin Support gVectors Support

    (@gvectorssupport)

    @odedta,

    You really don’t have solution for this!?

    Of cousre, there is a solution. You just need to exclude the wpForo pages from the Rank Math plugin settings:

    https://rankmath.com/kb/configure-sitemaps/

    odedta

    (@odedta)

    Hi, I added the posts to exclude field, no difference.

    Screenshot-3

    • This reply was modified 5 months ago by odedta.
Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.