Support » Plugin: Recipe Card » translation .po and .mo not working

  • Hello,

    I’m using the recipe card plugin on my website and although I followed all the steps to get it translated it doesn’t seem to work. I used the Loco translate plugin. It created the Portuguese tranlated .mo and .po files and uploaded to the language folder within the recipe card plugin main folder. I also checked the translated .po file on Poedit and it seems fine. But the Recipe Cards headers are still in English.

    Any ideas why it isn’t work?

    The site I need help is http://www.blogmangalo.com.

    thanks!

    https://wordpress.org/plugins/recipe-card/

Viewing 4 replies - 1 through 4 (of 4 total)
  • If you open the code of yumprint-recipe.php, you’ll see at line 60, what are required to change language.

    So, the name of your .po and .mo files should be:

    yumprint-recipe-pt_PT.po
    yumprint-recipe-pt_PT.mo

    and they must be in /wp-content/plugins/recipe-card/

    Enjoy!

    Hi Bruno,

    Thanks very much for your help. It finally worked!

    If anyone needs more info, I copied the .mo and .po files to /wp-content/plugins/recipe-card/language/ and the file names that worked for my Brazilian Portuguese blog were

    yumprint-recipe-pt_BR.po
    yumprint-recipe-pt_BR.mo

    Happy blogging!

    Hello,

    I have the same issue as above with the Romanian language.
    I have the yumprint-recipe-ro_RO.mo and yumprint-recipe-ro_RO.po files in /wp-content/plugins/recipe-card/ and the headers are still in english.
    I also tried to copy the files in /wp-content/plugins/recipe-card/languages, but still no luck.

    Any ideas?
    Thank you 🙂

    Hi, I have the same problem. I got my files from Loco translate and Uploaded them to the folder you said and it doesn’t work. Could be bacause I’m using a multisite? Thanks

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘translation .po and .mo not working’ is closed to new replies.