Support » Plugin: Subscribe2 - Form, Email Subscribers & Newsletters » Translation of the plugin

  • Hello Subscribe2,

    I just finished the translation of the plugin in French langage with Poedit.
    First time that a made a translation of a plugin.
    Actually the status of the translation is “Waiting”. What do excatly means ? Some people will check the translation to validate it.

    Also now i can export a .po file from poedit but looking at the folder of the plugin it don’t seem that /langages or .po / .mo file exist. Perhaps i’m wrong.
    But by which way i can use my translation file.

    Thanks for answers.

    Regards

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • Update,

    Well i success to change the language of the plugin.

    For those who could need the process :

    1.
    I made translation’s files into Poedit in French
    Output 2 files :
    -wp-plugins-subscribe2-dev-fr.po
    -wp-plugins-subscribe2-dev-fr.mo

    2.Theses files i place them into wp-content>languages>plugins

    3.Checking that my general settings of wordpress was in French

    4.At this step , the translation doesn’t work yet.
    One more action
    I rename the two files:
    -wp-plugins-subscribe2-dev-fr.po –> subscribe2-fr_FR.po
    -wp-plugins-subscribe2-dev-fr.mo –> subscribe2-fr_FR.mo

    5.Refresh and you got the plugin translate.

    ***
    Just, from my first post, one question:
    Actually the status of the translation is “Waiting”. What do excatly means ? Some people will check the translation to validate it.

    Regards

    Plugin Support mattyrob

    (@mattyrob)

    @stephnikel

    I presume you are translating here:

    https://translate.wordpress.org/projects/wp-plugins/subscribe2

    The Waiting heading means your translations are pending authorisation, you can request assistane I think from the translation teams here:

    Translation Teams

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Translation of the plugin’ is closed to new replies.