Support » Plugin: Leaky Paywall for WordPress » Translation of Stripe in Leaky Paywall

  • When I am logged in, the “Update Credit Card” section is in english even though the whole plugin is translated.

    The same happens with the popup payment box. It’s in english.

    Is it connected to Stripe somehow or how can I get this translated? Stripe says it’s a WordPress thing.

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Contributor Jeremy Green

    (@endocreative)

    Thanks for the heads up. We’ll make sure those strings are translatable in the next update.

    Thanks a lot. That’s a big help.

    When is the next update coming approximately?

    • This reply was modified 2 months, 1 week ago by  metusalem.
    Plugin Contributor Jeremy Green

    (@endocreative)

    We’ll have a new release sometime this week.

    Hi Jeremy,

    It’s still not updated? I am waiting for the update, to start being able to use your plugin, so if you have possibility to update it soon, I would really appreciate it 🙂

    I have been waiting for it more than 2 weeks now. I hope you have time to update it so we can start using your plugin? We want to pay you for the add-ons too, but first we need the language to work properly.

    Can you please give me a timeframe, so I know what to count on?

    Thanks a lot.

    Plugin Contributor Jeremy Green

    (@endocreative)

    We just pushed 4.10.9, which has the “Update Credit Card” string as translatable. We also added the data-locale flag to the stripe checkout popup so it will be in the language of your Stripe account settings.

    Thank you for your patience.

    Thanks a lot! Now the checkout is translated. But the subscription box is still not. Only some of the words… Can you fix that too? Thanks: https://www.screencast.com/t/Z1bM8r01

    When you are at it, I would like to price to be written like this: “28 kr. hver måned” – because that’s how we write prices in danish.

    How to I remove the “,00” after 28? Also on the Stripe checkout box that pops up? If I can not remove the two zeros, I just need to replace the comma with a dot to make it correct. So 28.00 instead of 28,00.

    • This reply was modified 1 month, 3 weeks ago by  metusalem.
    • This reply was modified 1 month, 3 weeks ago by  metusalem.
    • This reply was modified 1 month, 3 weeks ago by  metusalem.
    • This reply was modified 1 month, 3 weeks ago by  metusalem.
    Plugin Contributor Jeremy Green

    (@endocreative)

    Thanks for the feedback. We have added currency formatting options in Leaky Paywall v4.10.10

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.