Support » Theme: Hexa » Translation of standard wordpress elements doesn’t work

  • Resolved iroQuai

    (@stijnbiemans)


    I know its possible to change wordpress to another language, so that texts like “reply”, “continue reading”, or “Proudly powered by WordPress” are in another language (in my case: dutch).

    Hexa keeps displaying english texts although i’ve changed the settings to Dutch. I’ve double checked the settings and even used a fallback language (via a plugin) in case something was wrong with the chosen language (i tried with Dutch and Dutch-formal)

    If i switch themes to a standard wordpress theme or another 3rd party theme, translations do work. Changing to Quadra or Circa doesn’t fix the translations though.

    Any way to fix this?

Viewing 3 replies - 1 through 3 (of 3 total)
  • Hi there,

    I’m not sure why the translations aren’t downloading. They didn’t download for me either. However, you can still manually add the translations file and it should work.

    To do that, first visit the translation site for Hexa’s Dutch language here:
    https://translate.wordpress.com/projects/wpcom/themes/hexa/nl/default/

    At the bottom, look for the option to export the .mo file:

    Leave the left option as all current. Once you select the .mo file option from the list, click the Export link.

    Find the file on your computer and rename it from wpcom-themes-hexa-nl.mo to hexa-nl_NL.mo.

    The file needs to be uploaded into your WordPress directory here:

    /wp-content/languages/themes

    Once the hexa-nl_NL.mo file is in that folder, make sure that your site’s language settings look like this:

    (Note that this theme is not 100% translated. If you’d like to help finish the translations, you can find information on that here and here.)

    When you view your site, you should see the new translated strings. Here’s what it looks like on my demo site:

    When it comes to actually uploading the language file, one way to do that is by using an FTP client. You’ll need to contact your web host to request FTP access if you don’t already have it.

    The other way to upload the file is through a plugin that allows you to upload files.

    Either way, it’s recommended that you make a backup of your sites files and database anytime you’re making changes like this. That way if anything goes wrong, you can restore your site from a backup.

    You can find backup plugins to make this process easier here:
    https://wordpress.org/plugins/search/backup/

    Let me know if this works for you.

    iroQuai

    (@stijnbiemans)

    Tried it just now… works like a charm! thanks, this is resolved 🙂

    David C.

    (@dcoleonline)

    Awesome!

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Translation of standard wordpress elements doesn’t work’ is closed to new replies.