Support » Plugin: DeepL Pro API translation plugin » Translation not works

  • Resolved Rebecca

    (@misschaos)


    Hey guys,

    I installed the plugin. If I want to translate the page a request will be sent but I can not get a translation back. What’s wrong?

    Can you help me?

Viewing 15 replies - 1 through 15 (of 15 total)
  • Plugin Author Malaiac

    (@malaiac)

    Updated to v1.3 for WP 5.3

    Hi, still not working, neighter with WPML no without it)
    Classic Editor installed

    are there any updates planning?)

    Plugin Author Malaiac

    (@malaiac)

    if you say “not working”, I will answer “works for me” πŸ™‚

    What is not working ? What is the console output ?

    Cool answer))
    so, the error rises when i click button Translate – the endless loop starts.

    as i see the error is in file
    \wp-content\plugins\wpdeepl\assets\deepl-metabox.js
    line 85

    $.each( responses.data.translations, function( index, value ) {$.each( responses.data.translations, function( index, value ) {

    everywhere it call by jQuery but in this line – call by $

    error text: Uncaught TypeError: Cannot read property ‘each’ of undefined

    the second question – are there actual list of supported languages?
    For example, I dont see Russian, but DeepL supports it as i know.
    language list is hardly fixed in plugin
    Can you also check it ?

    thanks πŸ™‚

    • This reply was modified 8 months ago by aweselow.
    Plugin Author Malaiac

    (@malaiac)

    Will add Russian tomorrow.
    What does the previous line in the console looks like ? It should be the full response from the ajax call.

    Are you using Gutenberg ?

    no i use classic editor as recommended)
    console = do not remember,
    i fixed it as i wrote so it began to work πŸ™‚

    working edition:
    https://1drv.ms/u/s!AnsULaaFngkQk7BW1BaGrtF9Dk3Y5w?e=cG5MBH

    >>Will add Russian tomorrow.
    maybe add also Ukranian? it is also popular translate direction)

    Plugin Author Malaiac

    (@malaiac)

    Sadly, Ukranian is not supported by DeepL yet

    Thanks @awslaw! Your fixed version also worked for me, after I tried to run this plugin on WP 5.3 unsuccessfully.

    One thing I still noticed is that the plugin does not display the Deepl usage quota on the main plugin settings page. This worked before (installed on earlier versions of WP).

    Also, the <lang=”en”> tags don’t seem to work so I’m not sure yet how I am going to allow users to easily switch from one language to another. Does the Pro version of the plugin provide an easy method there (comparable to other translation plugins’ language flag switch, for example)?

    Plugin Author Malaiac

    (@malaiac)

    deepl-metabox.js fixed to work on all configurations.

    The “append” behaviour is expecting to find an active multi lingual plugin to take charge of the <lang> tags. Should it work differently ?

    Ah, I didn’t realise that the plugin works in tandem with an existing multilingual plugin, that’s great.
    Is there any particular plugin that you recommend works well with this, or is the <lang> tag universal?

    I tried installing Polylang, which seems to be the most popular translation plugin for WP. Can’t figure out the workflow in tandem with this plugin yet; when I click translate in an existing post, it opens an empty post, no option apparently to copy/paste the content into the new post.

    I have seen that before with WPML, which has the option to copy the existing text into the translated post, so that would work well with your plugin.
    But if you have suggestions I’d be interested, and it would make sense to list them in the documentation here, because when it all works this could be a top rated plugin and a better deal than any other DeepL solutions for WP out there.

    In addition to my last post: Polylang Pro offers the option of copying post content to the new post. This works really well with the plugin, so I opted for that.

    I am not sure which of the two things I did was the solution, but one worked:

    * I changed to the developer account – had the pro one before
    * I removed the blank after the API key that came from the Deepl website.

    I think it was the last, as then the number of characters left appeared. So, try the thing with the blank first, only then change your account.

    Hope it helps!!!
    Dietmar

Viewing 15 replies - 1 through 15 (of 15 total)
  • You must be logged in to reply to this topic.