WordPress.org

Support

Support » Plugins and Hacks » Product Catalog » [Resolved] Translation issue

[Resolved] Translation issue

Viewing 15 replies - 1 through 15 (of 15 total)
  • Plugin Author Rustaurius

    @rustaurius

    Hi Bolt,

    I’ve asked someone else who translated in Brazilian Portugese to help with this topic, since I don’t have any experience working with translations. If you do get Swedish working and you don’t mind if it’s included in the next update, that would be awesome.

    If he can help connect the files, sure I can share it.

    Hi, guys!

    I´ll put these files on wetransfer, and share the link with you:

    http://we.tl/OFPaWsDpA9

    I just put these files on lang directory in UPC! I believe thats could be an error by the translation program (I used Poedit, and it´s won´t work fine, so, I used the notepad++ to make some corrections…U can use translatin plugin to make sure that´s working fine, but if a light red bar is show up on top of wp screen there´s a mistake in some part of translation file. Check it!

    Best regards!

    Hi guys,
    I just made a lithuanian translation with poedit. http://we.tl/0U19RuoOfo Uploaded to upc/lang but nothings happens. 🙁 . I change in wp config file WLANG to lt_LT, but again nothing happens. Who can help me ?

    Hi, AdArt.

    PoEdit don´t work good for translate plugins (I don´t know why! Maybe I´m a bad/dummy user.). Use a translation plugin for this! In my post a week a go I explain my experience with Poedit.

    Best regards!

    Thanks for help Tito. I changed manualy php files 😀 Now I have plugin wit my language 🙂

    Found bug :)When I add more images. After refresh to dashboard.I got this:
    Warning: Missing argument 2 for wpdb::prepare(), called in /home/eshop/domains/domainname.eu/public_html/wp-content/plugins/ultimate-product-catalogue/Functions/Update_Admin_Databases.php on line 578 and defined in /home/eshop/domains/domainname.eu/public_html/wp-includes/wp-db.php on line 992

    I have full version.

    Hello,

    Can you please help me?

    I have also translated manually the plugin, but there are some character issues…

    The: áéíűőüö characters appears like this: �

    Help me please.

    Rob

    Hi, this characters need replace with php code leters. exp:
    ž – & # 3 8 2 ;

    Hi, people.

    Try to use “Easy Translation plugin”. It´s a very good plugin for translation jobs

    Hi,

    Thank you AdArt, your solution solved the issue 🙂

    Keep smiling (as I do)

    Rob

    Hi, guys!
    I had the same issue with Russian translation. Thank you, Tim, for your feedback. The solution is placing translation files into /lang/ folder with correct naming them: for me it’s
    ultimate-product-catalogue/lang/UPCP-ru_RU.mo
    ultimate-product-catalogue/lang/UPCP-ru_RU.po
    Placing files in subfolder or renaming them will disable translation

    callingelvis1

    @callingelvis1

    Hi, people,

    I tried to translate my UPCP plugin into dutch. But it won’t work.
    Also tried the Easy Translation plugin. But i get a warning!
    Warning: Invalid argument supplied for foreach

    What am i doing wrong?

    Plugin Contributor EtoileWebDesign

    @etoilewebdesign

    Hi callingelvis1,

    Unfortunately, I don’t have much experience working with translations so I’m not sure what’s causing you to get that warning.
    A great place to learn about how to translate a plugin is at the link below:
    http://premium.wpmudev.org/blog/how-to-translate-a-wordpress-plugin/

    There are a number of people who have translated it into their own languages already, so you can ask for their help on the support forum or check how they resolved their problems in earlier posts. I realize you are doing this right now but hopefully someone will respond.

    If neither of those help, send us another message and we’ll see what we can do!

    Also- Once you’ve translated the plugin, other users would love to have access to the files in your language. You can send them to us at Contact@EtoileWebDesign.com, and we’ll be sure they’re included in a future release.

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘[Resolved] Translation issue’ is closed to new replies.
Skip to toolbar