Support » Plugin: VikBooking Hotel Booking Engine & PMS » Translation issue

  • Resolved alarralde

    (@alarralde)


    Hello,

    I have the plugin installed in my multilanguage site. The translation works fine in general but the “oconfirm” view is not translated.

    For example:

    – The language of my site is in spanish so the plugin is translated into spanish.
    – I switch from home page to the page where I have put the shortcode of room
    details and I can see the plugin translated into spanish, all fine.
    – Then I start the booking process, I follow the process until I get into
    “oconfirm” view, the plugin shows it in english.
    – I continue to the “booking” view and it is translated again into spanish.

    I don’t have any clue about what is happening. I neither know if this is important but sometimes one of the shortcodes of the plugin I have in my site loses the translation and is displayed in english. I managed to solve it by adding another one shortcode in other page and deleting this new shortcode.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author e4jvikwp

    (@e4jvikwp)

    Hello,

    Thanks for the precise description of the issue. It is definitely something related to the configuration of the Shortcodes and their language, because the routing functions of Vik Booking read the relations between the Posts of your website and the Shortcodes.

    As you know, every Shortcode can take a language attribute, which defaults to * (any). Ideally, the routing functions should keep your current Post ID (permalink), which is taken from the very first landing page. For example, if you are using the Widget “Horizontal Search Form”, then the landing page URL can be controlled through the parameter “Page” of the Widget.

    We invite you to contact us directly from our website in case you have to report any strange behaviors. Thank you.

    Hello,

    Thanks for the quick response.

    I guess my shortcodes are fine, I have a total of 4 shortcodes in my site. Two of them are in spanish and the other two are in english. For example, in my spanish home page I have this shortcode:

    – [vikbooking roomid=”1″ view=”roomdetails” lang=”es-ES”]

    While in my english home page I have this one:

    – [vikbooking roomid=”1″ view=”roomdetails” lang=”en-UK”]

    I am using the plugin Polylang to switch between languages. So I show one page or the other depending on the language selected.

    I find weird that it only happens in the “oconfirm” view. It is also weird that after editing the spanish shortcode to lang=”*” and editing it back to lang=”es-ES”, now the shortcode is displayed in english always.

    Plugin Author e4jvikwp

    (@e4jvikwp)

    Hello,

    We will have to make some tests from our dev servers because it may be possible that the View “oconfirm” is not submitting some variables via POST, and so a different routing URL (Post Permalink) is taken for the landing page.

    In these cases we would appreciate if you could contact us from our website so that our programmers can try and reproduce the same situation on our servers.

    Hello,

    Ok I have sent a message to get in touch with your team regarding this topic.

    Greetings.

    Plugin Author e4jvikwp

    (@e4jvikwp)

    Thank you. I’m going to update this topic by clarifying that for the home page it is necessary to use the Widget “Search Form” rather than a Shortcode of Vik Booking.

    For all the rest of the pages of your website you can use Shortcodes of the plugin, but for the home page it is necessary to use the Widget, and to properly set its parameter “Page” to a page of your website where you have placed a Shortcode of Vik Booking.

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.