WordPress.org

Forums

Transposh WordPress Translation
[resolved] Translation Interface does not work after update 0.9.0 (14 posts)

  1. javpow_wp
    Member
    Posted 2 years ago #

    Hello.
    Your plugin (version 0.85) was working fine in my blog including the translation interface.
    After the update to version 0.9.0, the tanslation interface stopped working. It appears at the bottom of the page without configuration and I can't use it.
    How can I solve the problem?
    If it is not possible, Can I downgrade to version 0.85 without losing the translation and the work already done?
    Here is a link to the web: http://www.lejarraga.com

    Thanks a lot

    http://wordpress.org/extend/plugins/transposh-translation-filter-for-wordpress/

  2. Ofer Wald
    Member
    Plugin Author

    Posted 2 years ago #

    Since I can't see the edit interface on your site, I can only guess it has to do with the upgrade of version jQueryUI used internally.

    What you can do?
    Either change the version of jQueryUI to 1.8.24 in the constants.php file of Transposh, or.

    Find the offending jQueryUI version included somewhere else.

    Good luck

  3. javpow_wp
    Member
    Posted 2 years ago #

    Thanks for the quick answer.

    WordPress theme I am using includes jQueryUI version 1.8.17. Could be this the root of the problem?

  4. Ofer Wald
    Member
    Plugin Author

    Posted 2 years ago #

    Yes,

    So just change the constants.php file

  5. javpow_wp
    Member
    Posted 2 years ago #

    Hi,

    I have change jQueryUI version to 1.8.17 and 1.8.24 in the constants.php file, but the problem is not fixed.

    Should I change anything in the jquery.ui.menu.js file or include a new compatible jQuery UI file in the plugin directory?

    What else can I try?

    Thanks

  6. Ofer Wald
    Member
    Plugin Author

    Posted 2 years ago #

    Please contact me directly via the contact form on transposh.org, I guess I will need access to your site in order to help.

  7. javpow_wp
    Member
    Posted 2 years ago #

    I have sent you the access pass to the site via your contact form.

    Thanks a lot

  8. Ofer Wald
    Member
    Plugin Author

    Posted 2 years ago #

    Thanks,

    I missed another place (not the constants, but the transposh.js file) in which one needs to make this change as well (a bit harder, as the file is minified, but just look for 1.9.2 and replace)

    Hope things are fine now

  9. javpow_wp
    Member
    Posted 2 years ago #

    I was not able to find 1.9.2 in transposh.js file. The only reference to a jQueryUI version that appears is this:

    t_jp.jQueryUI="http://ajax.googleapis.com/ajax/libs/jqueryui/1.8.24/";

    Is that correct? Should I change the file?

    Thanks,

  10. Ofer Wald
    Member
    Plugin Author

    Posted 2 years ago #

    I changed it for you :)

    Aren't things working?

  11. javpow_wp
    Member
    Posted 2 years ago #

    Yes, the translation interface is working again!!!!

    Thanks a lot for your help. You are doing a superb job and the plugin is great.

  12. Ofer Wald
    Member
    Plugin Author

    Posted 2 years ago #

    Thanks,

    Marking this topic as resolved, feel free to rate the plugin :)

  13. La4emeDimension
    Member
    Posted 2 years ago #

    I have the same problem, and I change to 1.8.24 in content.php, but i don't find the verison in the transposh.js

  14. Ofer Wald
    Member
    Plugin Author

    Posted 2 years ago #

    Hi @La4emeDimension

    First, I would appreciate not replying to a month old resolved topics.

    Second, things have changed in 0.9.1, there is an option in the advanced settings tab, just write the version there.

    Good luck

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Transposh WordPress Translation
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic