Support » Plugin: Kadence WooCommerce Email Designer » Translation done but still in english

  • Hi,

    I have got a multilingual website, I translated everything but some word still appears in english. How can i do to resolve the problem please. I don’t find “Thanks for your order” to translate it.

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 16 total)
  • Hey,
    Which multilingual plugin are you using? Text like “Thanks for your order” is going to be data you save as the email header, meaning you define it in your settings and it’s not part of the translation. To make it multilingual you would have to use the string translation feature in your multilingual plugin to change the heading you set in the customizer for another language.

    Ben

    Thread Starter adelaydi

    (@adelaydi)

    Hi Ben,

    Thank you for your reply. I use WPML. I did the translation but it didn’t translate them.
    How can i send you screenshots?

    Regards
    Adélaïde

    This is different than translating because those are not static strings, those are output from the database based on what you set in your customizer settings.

    To translate customizer settings you have to use the string translation features in WPML.

    You can add screen shots using a site like this: https://imgbb.com/upload

    Ben

    Thread Starter adelaydi

    (@adelaydi)

    Thread Starter adelaydi

    (@adelaydi)

    I did the translation in string wpml as you can see on screenshots.

    Thread Starter adelaydi

    (@adelaydi)

    Hi,
    Did you have a look to my screenshots, can you help me to translate them please to appear correctly on mail.
    Best regards

    • This reply was modified 2 years, 4 months ago by adelaydi.

    Hey,
    thanks for posting screenshots, although I don’t see one showing you’ve edited the original text to make sure that has been saved and is not pulling from a placeholder. First, go to woocommerce > settings > emails and make sure your customer completed email heading text is set and not on a placeholder.

    I suggest you run this test, turn off our plugin ( you don’t need it to edit woocommerce header text) and navigate to woocommerce > settings > emails and make sure your customer completed email heading text is set. Then confirm it’s translated and clear your cache.

    Next log out and create a test order using the french version of your site. It’s important when you test to test with the user using the language you want the emails to be sent in.

    Check your emails.

    If everything is working without our plugin then turn our plugin back on and run the same exact test where you logout and use the french version of your site.

    Ben

    Thread Starter adelaydi

    (@adelaydi)

    Hi Ben,

    Thank you for your reply. Email heading text was completed, translations done. I turned OFF your plugin and email sent was correctly traduced. I turned ON your plugin, did another test, and the problem persists. I send you screenshots.

    Best regards

    Adélaïde

    Thread Starter adelaydi

    (@adelaydi)

    ok, WPML must be doing something different then before, what version of WPML are you using? What version of the Woocommerce extension. What version of woocommerce.

    Thread Starter adelaydi

    (@adelaydi)

    Woo commerce Version 3.9.1
    WPML Multilingual CMS Version 4.3.6
    WooCommerce Multilingual Version 4.7.7

    Thread Starter adelaydi

    (@adelaydi)

    HI,
    I still have the problem, do you have any solution please?
    Regards

    I have just emailed WPML to see if I can get some access and insight. I’ve not been able to recreate this using polylang.

    I will let you know when I hear something.

    Ben

    Thread Starter adelaydi

    (@adelaydi)

    Hi Ben,

    Ok, thank you for your reply,

    Regards,
    Adélaïde

    Thread Starter adelaydi

    (@adelaydi)

    HI,
    Ben,
    Any news?

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘Translation done but still in english’ is closed to new replies.