Support » Plugin: bbp last post » Translation

  • Resolved jaakko87

    (@jaakko87)


    Hi,

    for some reason the plugin doesn’t use the correct time format on my site. My site language is Finnish and normally it displays time like this:

    2016-05-02 klo 18:32

    But this plugin displays
    2016-05-02 at 18:32

    I know, it’s not a big thing but just saying 🙂

    https://wordpress.org/plugins/bbp-last-post/

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Robin W

    (@robin-w)

    bbPress.org Moderator

    Thanks for your post.

    You could help by translating this plugin for me, and then it would work in Finnish, and help others !

    If you go into the files (you can download them to your PC) and using any editor go into

    /lang/bbp-last-post.pot

    then you can translate this plugin into Finnish.

    You will see that each piece of code has for instance

    msgid “A list of the most recent replies.”
    msgstr “”

    so if you put the equivalent into the msgtr string eg (according to google !)

    msgid “A list of the most recent replies.”
    msgstr “Luettelo Viimeisin vastaukset”

    And then send me this file once all the strings have been done, I can add use this to create a finnish translation, and then as long as your wordpress site is set to finnish, it will automatically use this.

    Currently I’m not using the widget so apparently the only string I need translated is that “at” preposition. If (or when) I enable the widget then I will of course translate everything and can submit the translation to you. It’s difficult to translate without seeing the strings in context. In general Finnish language is not very good for expressing things with a few short words.

    Plugin Author Robin W

    (@robin-w)

    bbPress.org Moderator

    no problem, in that case if you know how to edit files, then go to

    includes/functions.php line 27
    includes/functions.php line 54
    includes/lp-widgets.php line 123
    includes/lp-widgets.php line 134

    and just amend ‘date at time’ to ‘date klo time’

    and save

    you will need to do this again on upgrades

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Translation’ is closed to new replies.