Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Support Nayeem-Ul-Islam Nipun

    (@nayeem-ul-islam-nipun)

    Hello @alexbyby,

    Greetings. Hope you are doing well.

    Regarding your issue, I would like to suggest you to download and install the Dev Version from the below link and check again and let me know if this works for you or not.

    BetterDocs Dev: https://d.pr/f/PHak27

    After that please rest the permalink To rest the Permalink please check this video: https://d.pr/v/lGOjg5

    After doing this please check the issue again.
    Again we apologize for the inconvenience.

    Let me know how it goes.

    Thanks and Regards.

    Plugin Support Nayeem-Ul-Islam Nipun

    (@nayeem-ul-islam-nipun)

    Hi there,
    Greetings. Hope you are doing well.

    I am delighted to let you know that the latest, improved, and optimized versions of Free & Pro BetterDocs v2.5.2 have both been released.

    The release of a new version that addresses certain issues. We’re optimistic that this update will result in a seamless experience.

    Would you be so kind as to update both the FREE and PRO versions to 2.5.2 and share your feedback with us?

    Your valued response is eagerly awaited.

    Thank you.

    Thread Starter alexbyby

    (@alexbyby)

    I did everything as you asked, result; translation from file.pot doesn’t work look here >

    http://www.apdigital.it/Immagine%202023-08-20%20192124.jpg

    TRANSLATE FROM ITALIAN TO ENGLISH FROM THE SCREENSHOT

    However if I try to get direct translation from file in your path > betterdocs\includes\Core\Settings.php
    so I translate from English to Italian I don’t get the same result on the screen printed in Italian.
    Of course I clear cache from the server as well as from the browser during testing.
    Translation failed!

    • This reply was modified 6 months, 1 week ago by alexbyby.
    • This reply was modified 6 months, 1 week ago by alexbyby.
    • This reply was modified 6 months, 1 week ago by alexbyby.
    • This reply was modified 6 months, 1 week ago by alexbyby.
    Plugin Support Nayeem-Ul-Islam Nipun

    (@nayeem-ul-islam-nipun)

    Hi @alexbyby ,
    Hope you are doing well. Really sorry for the inconvenience.

    Regarding your issue, can you please share a screencast of the procedure you tried to translate the BetterDocs? It seems you were trying to edit the .pot file directly without using any Translation plugin.

    If you are using any translation plugin please let me know the name of the plugin as well.

    Thanks.

    Thread Starter alexbyby

    (@alexbyby)

    I’m surprised you ask me this question when it comes to file.pot
    As you well know, in reality you don’t need any translation Plugin if you use the well-known ‘Poedit’ program
    in fact Poedit allows you to translate the file into any language and generate the files that can be used in order to obtain the translation you need.
    In any case, when opening the file as I showed you in the screenshot, there is already a problem with double lines which will be fixed automatically by the program itself saying that perhaps this problem will unpack all the translations.
    So in conclusion I can tell you that I have successfully used it to translate over 100 PLUGINS, which doesn’t happen with yours.
    I hope I have been of help. Greetings.

    Plugin Support Nayeem-Ul-Islam Nipun

    (@nayeem-ul-islam-nipun)

    Hi @alexbyby,
    Greetings. Hope you are doing well. Really sorry for the inconvenience.

    Regarding your query, I check the issue and edited the .pot file using Poedit software and created a file for Italian language and it works for me. For reference please check this screencast – https://d.pr/v/sjFHRk

    Here you will find the full procedure step by step to create and edit pot file.

    For you convenience, you have to open and edit the .pot file from wp-content -> plugins -> betterdocs -> languages -> betterdocs.pot and when you save the .pomo file you need to save it on wp-content -> languages and add a prefix betterdocs- just before the language .pomo file name.

    Hope this will help you out. Please let me know how it goes. If you still face any issues I would like to recommend you to share a screencast of the issue you are facing so that I can help you out.

    Thanks and Regards.

    Thread Starter alexbyby

    (@alexbyby)

    So to enable the Enable Multiple Knowledge Base check I have to switch to the PRO version is this what you are telling me?
    In the case of a positive response in this regard, it seems to me quite risky as a restriction, after all it is not that the plugin provides a perfect or ready-made translation, everyone translates it at their own expense, therefore, according to my humble point of view this check should be unblocked. Greetings

    • This reply was modified 6 months, 1 week ago by alexbyby.
    • This reply was modified 6 months, 1 week ago by alexbyby.
    Plugin Support Nayeem-Ul-Islam Nipun

    (@nayeem-ul-islam-nipun)

    Hi @alexbyby,
    Greetings. Hope you are doing well.

    I really appreciate your suggestion. I will definitely discuss about the restriction with our Dev Team and hope they will take necessary steps for this.

    Please feel free to reach out anytime you have issues or queries. We are always here to assist you.

    Thanks and Regards.

    Plugin Support Nayeem-Ul-Islam Nipun

    (@nayeem-ul-islam-nipun)

    Hi @alexbyby,
    Greetings. Hope you are doing well.

    I am delighted to let you know that the error issue with the pot file edit is resolved in our latest BetterDocs v3.0.0. I checked the full process and didn’t found any error with v3.0.0.

    I would like to suggest you to check the BetterDocs v3.0.0 and try to edit the pot file directly from wp-content -> plugins -> betterdocs -> languages -> betterdocs.pot and when you save the .pomo file you need to save it on wp-content -> languages and add a prefix betterdocs- just before the language .pomo file name.

    Please let me know how it goes.

    Thanks and Regards.

    Plugin Support Nayeem-Ul-Islam Nipun

    (@nayeem-ul-islam-nipun)

    Hello @alexbyby,
    Greetings! Hope you are doing well.

    We haven’t received any updates regarding the issue mentioned earlier. Could you please let us know if the issue still persists or not?

    We would greatly appreciate an update. Thank you.
    Have a good day!

    Plugin Support Nayeem-Ul-Islam Nipun

    (@nayeem-ul-islam-nipun)

    Hello alexbyby,
    I hope you are doing well.

    About your issue, We still haven’t heard back from you. So, I am assuming your issue has been resolved. I am resolving this topic.

    I wanted to let you know that you are always welcome to re-open the topic if you have any further questions or concerns.

    Before opening a new request, however, I kindly request that you take a moment to read through this post. It may contain the answers to your questions or provide you with a solution to your issue. If you still require assistance after reading this post, please do not hesitate to reopen the thread or submit a new request.

    Thank you for your attention to this matter. I look forward to hearing from you soon.

    Have a nice day!

    Thread Starter alexbyby

    (@alexbyby)

    Yes, the problem has been resolved and I am continuing to translate the entire Plugin, as soon as I have finished with the translations I will upload the entire translation to your page.
    Thank you for your interest and support, 5 stars for me.
    Greetings

Viewing 12 replies - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.