Support » Plugin: Polylang » Translated categories don't show up

Viewing 6 replies - 1 through 6 (of 6 total)
  • What category? Everything seems translated to me…

    It’s “only seems”. I was able to translate pages, but not categories. Since my site oriented towards Russian customers I have 1 category in English (it is not translated) and the rest in Russian.

    I see…
    Are you sure you’ve created the oslo-tips category in Russian and correctly linked it to the English version?
    Also, your permalinks are a bit weird, you have both http://oslophototour.com/en/category/oslo-tips/ and http://oslophototour.com/en/oslo-tips/

    Furthermore, do you have access to your theme files? If yes you might want to add a language variable to the loop showing the bottom category, something like:

    <?php $lang = substr(get_locale(), 0, 2); ?>
    <?php $yourquery = new WP_Query( array( 'lang' => $lang )); ?>

    Hi Teolives, sorry being away for too long.
    Honestly I don’t know where to add the code you have posted. Before we getting in the issue I’ll try to explain what kind of problem I have. While adding an extra language in menu I was using “empty” and “main”. Unfortunately I don’t find something similar for categories or perhaps I do something wrong.
    Can you suggest what to do?
    thank you in advance,
    Rami

    Sorry, I’d been away from these shores for a while as well.

    I don’t get this:

    I was using “empty” and “main”

    What do you mean?

    I think if you go to Post -> Categories, you should be able to link the Russian and the English category (you should click on the category you would like to associate to the other language and in the bottom part of the screen, in a dropdown box, you’ll find a list of untranslated categories).

    Also, do you have the same post translated in both languages? When I’m on your English page I see Russian articles and viceversa: link the two articles together by entering the other language’s post ID in the language box in the edit post screen (you’ll find the post ID by hovering over the post name in the post list. If the language box is missing in the edit post screen, check your screen options)

    Hope this helps… we’ll sort it out.

    Dear teolives thank you for coming back. Is it any way how I can attach print-screens? It seems like I have a theme limitations.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Translated categories don't show up’ is closed to new replies.