• Resolved erfanit

    (@erfanit)


    Hello,

    I would like to translate “Sold By” into Italian. I have tried any possible way that I found, but No success. I am using Loco Translator which works quite fine for other plugins but unfortunately not with WC Vendors.

    Could you please let me know how I can translate “Sold By” and “Become a Vendor”?
    I have Polylang and Loco translate. And En and iT languages.

    Cheers!
    Erfan

    • This topic was modified 1 month, 4 weeks ago by  erfanit.
Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Jamie

    (@digitalchild)

    Hello,

    Loco Translate is our recommended translation tool to translate wc vendors. Are you creating your own translation or using the old translation files that are included with the plugin? Please make sure you sync the translation file and save before trying to update.

    We also provide sold by labels you can update in the wp backend. If you have saved the settings then the translations will not work as the labels are stored in the database after this and referenced.

    Make sure to update the labels in the database also.

    WC Vendors > Settings > Display > Labels

    cheers

    Jamie.

    Hi Jamie,

    -I am using the old translation files that are included with the plugin.
    -I did sync the translation file and saved it before trying to update it.
    -I have changed several times the labels in:
    WC Vendors > Settings > Display > Labels
    Now my sold by label is: “Sold By”

    What I want is to see “Venduto da” instead of “Sold By” when the website changes from English to Italian (using Polylang).

    * Now I can translate other sentences in Loco. Like “Become a vendor”, and …
    They work fine.

    I do not know how to update the labels in the database! If you assume this is the issue, could you please help me out to do it?

    Cheers!
    Erfan

    After trying several methods and tricks, I still could not translate “SOLD BY” to Italian.
    I will be appreciated if you give me some hints to work on!
    Bests

    Plugin Author Jamie

    (@digitalchild)

    Hi Efanit,

    This is because the English version of the label is saved in your database. You would need to delete the labels from the database, load the translation. Then save the labels again. This will then save the italian version in the database for reference.

    You need to remove this option – wcvendors_label_sold_by from your database.

    cheers,

    Jamie.

    Plugin Author Jamie

    (@digitalchild)

    On further digging I do believe this is also a bug. In the mean time you should be able to go to WC Vendors > Settings > Display > labels and change all those labels to your Italian required versions to store the Italian versions in the database.

    You can follow the bug report here: https://github.com/wcvendors/wcvendors/issues/579

    cheers,

    Jamie.

    Hi Jamie,

    Thank you. I follow the bug report.
    I hope it will fix soon as it has a big impact on my website!

    Cheers!
    Erfan

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.