• Resolved LinuC

    (@linuc)


    Hi

    I am using Better Docs free version and now I am translating my website using Falang.

    Falang is a very modern translation plugin and uses the entity method. It means that NO new document is created for the translation, as is usually the case, for example with polylang.

    Now I see that TOC is not translated. I have no way in Falang to translate the entries into TOC, so I suspect that TOC is created in runtime and is NOT a stored item. Obviously Better Docs always takes the entries for TOC from the base page, in my case the English one.

    How can I modify Better Docs’ code to use Falang’s translation to create TOC? I have very little programming knowledge, but with good guidance I can change a php or css file.

    In the example page you can see a spanish translation of a document, but with english TOC. Click on the US flag in the sidebar and you will see the basic English version. Only this document exists for this title. The translation is linked to this document and is not his own document. This is the entity method.

    Many thanks for the help!

    The page I need help with: [log in to see the link]

Viewing 11 replies - 1 through 11 (of 11 total)
  • Thread Starter LinuC

    (@linuc)

    Some more information about entity method:

    Entity Translation is the newer method
    Content Translation is the older method

    The Entity Translation allows entities (such as nodes) to be translated into different languages. Entity Translation provides field-level translation, so that site builders can select which fields should be translatable.

    Sometimes it is also called field translation.

    No copy of the page is created and then translated, but the individual parts of the page are converted into entities (fields) and translated individually. Each entity (field) then has several translations, depending on the number of languages. If the basic page is called up, the content of the entities (fields) is replaced according to the language set.

    Thread Starter LinuC

    (@linuc)

    Some first information from Falang:

    Falang store the translation in the meta of each post
    exept for the builder page (dive, elemtor, wpbakery and soon yootheme)

    Plugin Support Abid Hasan

    (@abidhasan112)

    Hi @linuc ,

    Hope you’re doing good.
    BetterDocs currently not support the Falang plugin for multilingual solution fully.

    I would recommend you to use the popular translation plugins (ie. WPML ) to translate your BetterDocs articles along with TOC.

    If we get more such requests in the future for the Falang plugin integration, we will definitely work on it in our plugin in the future.

    Thank you!

    Thread Starter LinuC

    (@linuc)

    @abid Hasan

    Thanks for letting me know!

    I can’t use WPML as I don’t have the money to pay for it. And I couldn’t find a free plugin with entity translation, except for Falang.

    So I’ll have to live with the situation until you integrate Falang. At the top right of my page there is also a language switcher for Gtranslate automatic translation in case someone absolutely needs to see the TOC in their language. It’s just a few words.

    Please let me know when Falang is completely working with Better Docs. I think it’s just TOC, everything else seems to be working fine.

    have a nice sunday
    Patrick

    • This reply was modified 4 months, 3 weeks ago by LinuC.

    Hi,

    i will see if i can find a solution and post it in this thread.

    Best regards,
    Stéphane
    Falang Team

    Plugin Support Abid Hasan

    (@abidhasan112)

    Hi @linuc ,

    I understand!
    You can also try to translate with TranslatePress plugin: https://wordpress.org/plugins/translatepress-multilingual/

    We used TranslatePress on our website aswell.

    I can’t give you any ETA right now when we will work to make BetterDocs fully compatible with Falang plugin. If we get more requests in the future we will work on it don’t worry.

    Thank you!

    Thread Starter LinuC

    (@linuc)

    @abidhasan112

    I am working with Falang, because it is done by an experienced man. I am not interested in any other translation plugin.

    I hope Better Docs can solve this little problem soon.

    greetings
    Patrick

    Hi,

    This can work with a little change in the BetterDocs plugin.

    in the file
    wp-content/plugins/betterdocs/public/betterdocs-shortcodes.php
    line 880 change
    $get_post = get_post($get_args[‘post_id’]);
    $post_content = $get_post->post_content;
    to
    $post_content = apply_filters(‘the_content’, get_the_content());

    it will work in the same way because the $get_args[‘post_id’] is get with get_the_ID()

    Best regards,
    Stéphane
    Falang Team

    Thread Starter LinuC

    (@linuc)

    @sbouey

    Thank you so much Stéphane!

    I put it in betterdocs-shortcodes.php like this:

    880/*  $get_post = get_post($get_args[‘post_id’]);
     881    $post_content = $get_post->post_content;  inactiv LinuC */
     882   
     883    $post_content = apply_filters('the_content', get_the_content()); /* Code Falang */

    This way you still have the original code and the correction of Falang is marked.

    It is important to note that Falang’s code has the correct quotation marks before and after the_content. Italic doesn’t work!It must be “straight” quotation marks. See the difference to Stéphane’s post, please.

    And don’t forget to turn off Better Docs auto update so that the correction isn’t overwritten unnoticed. As soon as Better Docs sends an update, run it and then check the translation of TOC. If it no longer works, you have to repeat the correction in betterdocs-shortcodes.php. So please keep the Falang code including the line numbers.

    Apparently the correction of betterdocs-shortcodes.php doesn’t always work. WordPress plugin editor reports an error. So you have to download betterdocs-shortcodes.php and change locally, then upload again to the server. Or make the correction directly on the server with the editing function of the editor of the host server.

    Thread Starter LinuC

    (@linuc)

    Hi

    There was a update from Better Docs. But the change for Falang was not yet part of it.

    If you use Falang and if you need the translated TOC, please follow the instruction in the last post. Just the line numbes have changed. It is now in line 893 and 894.

    Thanks!

    • This reply was modified 4 months ago by LinuC.
    Thread Starter LinuC

    (@linuc)

    @abidhasan112

    Hi

    After a few updates from Better Docs, the falang code has unfortunately not yet been implemented. It would be great if you could do that 🙂

    signature moderated:

    Forum Guidelines

Viewing 11 replies - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.