Support » Plugin: My Calendar » Translate string “Week of”

  • Hi!

    Does anyone know how to translate the string “Week of” which is shown when displaying a calendar by week? I use WPML and can’t find this in string translation. My French and German calendars display this string in English.

    Thanks!

    Edit: I saw that the my-calendar domain was missing in WPML. I had to scan for it and now the domain is showing. Still, this particular case of ‘Week of’ doesn’t appear in string translation.

    • This topic was modified 3 months, 3 weeks ago by fredvdp.
    • This topic was modified 3 months, 3 weeks ago by fredvdp.
    • This topic was modified 3 months, 3 weeks ago by fredvdp.
Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Joe Dolson

    (@joedolson)

    So, turns out there are two strings like that, and only one of them was properly internationalized. I didn’t notice largely for two reasons: 1) there are two versions of this string and 2) the one that wasn’t internationalized is configurable as a setting, so you don’t necessarily see the ‘Week of’ text if you’ve configured something else.

    Will get that domain added in the next release.

    Thanks, Joe!

    If it’s not too much trouble, I have another problem with my French calendar.

    In the settings I have set date formats to j F Y (e.g. 29 September 2020). If I set the calendar to week view, the strings top left where you see ‘week of’ are formatted ‘septembre 4’.

    In the settings, I don’t see a customization option for the date format in this particular string. Am I overlooking it, or is there some other way to set it to the French format?

    Kind regards

    well, after all the prior translation requests i have one that i did not dear to ask before but now i do 🙂
    in the upper right corner of the list view one can read:
    Events (and then the period)
    i would like to translate the english Events into Activiteiten and tried so in the Translation modules i found but in this particular case the word Events remains the same all the time; is there anything i could do to change this?

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.