WordPress.org

Support

Support » Themes and Templates » Minamaze » Translate "Read More" tag to Spanish

Translate "Read More" tag to Spanish

  • Hello all,

    I’, trying to translate the “Read More” tag to Spanish “Seguir leyendo” but I can’t find the way to do it.

    Can you please help me?

    Many thanks in advance,

    David Sánchez

Viewing 15 replies - 1 through 15 (of 20 total)
  • Theme Author ThinkUpThemes

    @thinkupthemes

    Hi David,

    The easiest way to translate Minamaze is to use the fantastic Codestyling Localization plugin. You can download the plugin for free right here from WordPress.org. Here’s a link to the plugin page:

    https://wordpress.org/plugins/codestyling-localization/

    Simply download the plugin and us it to create the relevant spanish language file. You may find the following YouTube video useful on learning how to use the Codestyling Localization plugin:

    Let me know if you have any problems and I’ll be sure to help. Minamaze is fully compatible with this plugin, so hopefully you wont run into problems.

    Hello !

    Many thanks for your help but I have this error message on the Codestyle Localization

    Malfunction at current Theme detected!
    Name: Minamaze | Author: ThinkUpThemes
    Below listed scripts has been automatically stripped because of injection:
    ◦http://gabrieljdelatorre.com/wp-content/themes/minamaze/lib/scripts/main-backend.js

    Can you help me?

    Because I can change the translation and do the .mo file but it’s not working.

    Many thanks again !

    David

    Theme Author ThinkUpThemes

    @thinkupthemes

    Hi David,

    That isn’t technically an error. The plugin will prevent any scripts that are not core WordPress from loading. You can still use the plugin. That script is a Minamaze specific script so won’t actually cause any issues.

    If you create the translation files, then scan and then output the .mo and .po files you can then use the translated files. You’ll need to change the line wplang in your wp-config file also to match the language name.

    Have you changed your wp-config file yet? Note, that this process is not theme specific so if you do get stuck you can just google for a translation tutorial and you should fine one.

    Let me know how you get on.

    Hello again,

    Finally I found it without using the codestyle localization.

    You need only to modify the file homepage.php on the location

    /wp-content/themes/minamaze/admin/main/options

    The codestyle localization wasn’t working.

    Many thanks,

    David

    Theme Author ThinkUpThemes

    @thinkupthemes

    Hi David,

    I really wouldn’t edit that file. That is where you’ll find the core code, however your changes will be overwritten in a theme update. Minamaze is definitely 100% compatible with Codestyling Localization, many of our users translate using it.

    If you like I can arrange for someone to walk you through the translation process.

    Thanks,

    Afzaal

    Hi there.
    I installed the “Minamaze” plugin. I have generated the “es_ES.po” files and “es_ES.mo”. I have checked the language in the “wp-config.php” file and the translation does not work, eg “Read More” to “Leer más” or “Search” to “Buscar”
    A greeting.

    Theme Author ThinkUpThemes

    @thinkupthemes

    Hi guys,

    @davidsanchezdegroeve and @fexco

    Apologies, yes you are right. The translation functionality needs a slight adjustment. This will be fixed in the next update.

    In the meantime this is how to get the translation working correctly.

    • Open functions.php
    • Go to line 57
    • Change /lib/languages to /languages

    If anyone is having trouble with this specific fix please contact us through our main site and we’ll help with this issue.

    Apologies for any inconvenience caused! We’ll work with you to get it sorted so you can go about translating as normal.

    Thanks.

    Hi.

    After change the line 57 in functions.php (/lib/languages to /languages), the theme show again the same text.

    A greeting.

    Theme Author ThinkUpThemes

    @thinkupthemes

    Hi Félix,

    As mentioned in the meantime until the fix is in place we’re happy to offer support through our main site for this 1 issue. The above correction has been tested on our end and it’s working fine.

    Please contact us and we’ll get a meeting setup.

    Thanks.

    Thanks for the replies.

    I’ll wait to update it.

    A greeting.

    It worked perfectly for me. Thank you very much!

    Dear ThinkUpThemes:

    I’d like to offer, as a courtesy, the theme translation to Portuguese and Spanish if you like to add to the original package.

    Saúde!
    m.

    Esto es lo que yo hice y me funciono.

    Entrar al hosting.
    Ir a sus Archivos
    public_html/wp-content/themes/minamaze/admin/main/options/
    Buscar el archivo 02.homepage.php
    Abrirlo con el editor de texto preferido
    Buscar donde dice ‘Read More’ (lo encontré 4 veces)
    Cambiar por el texto que usted elija (por ejemplo… Leer más).
    Guardar los cambios y cerrar.
    Verificar los cambios en el blog.

    Recuerde que siempre es conveniente crear una copia de respaldo antes de hacer cambios.

    Saludos.

    Theme Author ThinkUpThemes

    @thinkupthemes

    @marco

    Thank you very much for the kind offer! Can you contact us over at http://www.thinkupthemes.com and we’ll give you the details of where to send the relevant files. Thanks again! 🙂

    @dianaluzreyes

    Thanks for the instructions for users. In the next update this string will be translation ready. Thanks for the great feedback!

    Hi There

    I’ve used the Codestyling Localization plugin for tranlating many of the labels. However if the plugin cannot find the “Home” label. Any ideas how can I change/translate it ?

Viewing 15 replies - 1 through 15 (of 20 total)
  • The topic ‘Translate "Read More" tag to Spanish’ is closed to new replies.
Skip to toolbar