Support » Plugin: Polylang » Translate media but don’t lose images in existing posts

  • Hi,

    Unfortunately I only learned about the option to translate media in Polylang recently (also, didn’t need it before). I have a website where every post/page is available in two languages and contains many images. When I activate the media translate feature now, all the images in all the posts and pages disappear (I know that they are still available under Media).

    Is there a way to create the translations for both languages automatically based on what is currently written in the captions? I would then go through the images one by one to add the correct translations over time. But losing all the images from all the posts/pages at once is a bit of a nightmare as there are 100s of them.

    Thanks

Viewing 3 replies - 1 through 3 (of 3 total)
  • Are you using Jetpack for your galleries?
    There is a big problem with Polylang and the medias.
    I have a site with pages in French and English.
    I have many galleries made with Jetpack. It works in French pages but no images appear in English pages, no galleries work in English pages.
    Everything worked perfectly with Polylang 2.7. But with 2.8 it is a nightmare and the developer is not responding to any thread on this issue.
    The support for this plugin is terrible!
    90% of the subjects are unanswered.

    I am not using Jetpack or any plugin for galleries, I have my own solution for images.

    Do you know a better plugin for translation by any chances, where I can translate media easily? Thanks!

    Plugin Author Chouby

    (@chouby)

    Hello,

    When I activate the media translate feature now, all the images in all the posts and pages disappear (I know that they are still available under Media).

    That’s expected if you don’t assign a language to existing media. See https://polylang.pro/doc/assign-a-language-to-an-existing-content/

    Duplication of media in another language is a feature of Polylang Pro only (automatic duplicate at upload, bulk duplicate, automatic duplicate of media included when creating a new post)

    @egrefin Please don’t pollute other topics.
    According to our tests, there are no issues with Jetpack galleries. Your issue rather looks like the one reported in this topic https://wordpress.org/support/topic/polylang-elementor-3/. As I explained there, it looks like a few users took profit of a bug that we fixed in 2.8 and inserted images in the wrong language. They were previously displayed. That’s not the case anymore.

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.