Support » Plugin: WPAdverts - Classifieds Plugin » Translate Location string

  • Hi Greg, I need help with the translation location string. I already use Loco Translate and language plugins. My site is translated into two languages: Ukrainian and Russian. When I write in the ad location string (in Russian) “street 1” and save the changes, I see the same “street 1” in Ukrainian – the translation, of the line that i write, is saved in both languages at once, and I cannot translate into each language separately. Other strings are translated and saved correctly.

Viewing 9 replies - 1 through 9 (of 9 total)
  • Thread Starter vasian4515

    (@vasian4515)

    The same thing with string of ad authers name, when i write his name it is saved in both languages at once.

    Plugin Author Greg Winiarski

    (@gwin)

    Hi,
    i am not exactly sure which strings are you trying to translate?

    If you mean the location and the author name you enter in the [adverts_add] form when submitting the Ad then I am afraid it is not really possible to translate this data with Loco Translate (or any other translation plugin) as it is being saved in the database, the best solution would be to post the Ad twice once in Russian and once in the Ukrainian language.

    Thread Starter vasian4515

    (@vasian4515)

    I mean that ad is already exist in russian and ukraine version (languages plugin), but when i am trying to change, name or location strings (they are shown on front ad page) at any language, it is saved the same at other language. I cant save different words, in different languages (Ukraine or Russian), only in those strings of ad. When i am editing ads from admin panel. Please see https://kurortov.com/advert/pansionat-villa-lotos/ – rus. version, string name “Елена” and location string “ул. Черноморская 8А” and the same ad in ukraine version https://kurortov.com/uk/advert/villa-lotos/ the same words in strings. But they are spelled differently in UK and RUS. I can change it, but only for both languages at once.

    • This reply was modified 3 months, 4 weeks ago by vasian4515.
    • This reply was modified 3 months, 4 weeks ago by vasian4515.
    • This reply was modified 3 months, 4 weeks ago by vasian4515.
    • This reply was modified 3 months, 4 weeks ago by vasian4515.
    • This reply was modified 3 months, 4 weeks ago by vasian4515.
    Plugin Author Greg Winiarski

    (@gwin)

    I am afraid that might be a conflict with the multilingual plugin you are using or maybe not as much as a conflict but rather we do not have an integration with any multilingual plugin so the WPAdverts does not know how to handle the multilingual data.

    Can you let me know what plugin are you using to handle the ads in different language versions?

    I can’t promise I will be able to help you with that since most likely this will require me to dig into the plugin source code but I can take a look and see if there some quick fix possible.

    Thread Starter vasian4515

    (@vasian4515)

    I sent version of plugin to https://wpadverts.com/contact form

    Plugin Author Greg Winiarski

    (@gwin)

    Hi,
    thanks, i got a message from you and you should receive a reply soon.

    The message did not include any files but you can reply to it as to any other email message and include the translation in the attachment.

    Thread Starter vasian4515

    (@vasian4515)

    Thank you, I’ll be waiting.

    Thread Starter vasian4515

    (@vasian4515)

    Tell me please, how to hide only “Send message” button (“Отправить сообщение”) and disabled this function?

    Plugin Author Greg Winiarski

    (@gwin)

    The send message button is most likely coming from the Contact Form module, so in order to disable it go to wp-admin / Classifieds / Options panel and deactivate the contact form module.

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.