Support » Plugin: Polylang » Translate Custom Post Type when not public queryable

  • Resolved netzgestaltung

    (@netzgestaltung)


    Hi there,

    this time i started testing with not public queryable post types and this is what happens with polylang:

    1. if the post type is NOT public queryable: no setting checkbox for that in Languages/Settings/Custom Post Types and Taxonomies, no possibillity to activate it.

    2. if i set it to public queryable: the setting checkbox appears.

    3. if i check it and then reset the post type to NOT public queryable: i can translate it now and the languages show up in post-edit-list and post-edit views, the checkbox in Languages/Settings/Custom Post Types and Taxonomies disapears again.

    if you find that this behaviour is a bug, this information may help to find it.

    cheers
    tom

    ps: what i use to set CPTs: https://wordpress.org/plugins/custom-post-type-ui/ – also https://generatewp.com/post-type/ will save you some time.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Chouby

    (@chouby)

    Hi,

    This is the intended behaviour, to avoid non-developpers to mess with non public post types.

    As a developer, you can filter the list of translated post types, either with the filter pll_get_post_types or a wpml-config.xml file. See: https://polylang.pro/doc-category/developers/

    Otherwise, Polylang Pro includes a specific compatibility with CPTUI, and in this case, the setting is present for all post types registered with CPTUI, public or not.

    thank you for clearifying!

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.