Support » Plugin: DeepL Pro API translation plugin » Translate button not doing anything

  • Resolved schalipp

    (@schalipp)


    Hi,

    we have installed the DeepL wordpress plugin and entered the correct API subscription key. Settings page shows available 1,000,000,000 words contingent.

    On the edit post view, the DeepL box with the translate button is displaying correctly, but whenever we click on this button, the little grey circle icon just keeps spinning for hours, and nothing else happens. No translation is taking place.

    What are we missing?
    Thank you for any help.

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • dietmarfischer

    (@dietmarfischer)

    Hi schalipp,
    what did the trick for me: if you copy the API code from Deepl, it adds a space in front of the code. Once I removed that, it worked – although not like a charm, the pictures were not where they were supposed to be.
    Hope that helps,
    Dietmar

    dietmarfischer

    (@dietmarfischer)

    PS: With another article, the pictures were all right, though…

    schalipp

    (@schalipp)

    Hi, thanks for answering. I checked, but there is no accidentially copied space in front or at the back our API key, it has the correct format. But when we click on the translate button, the icon just keeps spinning. No error message, no translation, nothing.

    Problem is still unresolved. Maybe the developer can help us? Is this plugin actively supported?

    Solved. The plugin as it is, is not compatible with current wordpress versions. I have found the bug and corrected it. If anyone else needs this:

    The error is in “/wp-content/plugins/wpdeepl/classes/deeplapi.php”.
    The method “buildQuery” was not building the post request conforming to WordPress API standards. Here is the fix:

    protected function buildQuery( $mode = ‘POST’ )
    {

    if ( $mode == ‘POST’ ) {
    /* POST body has to be an array and NOT a queryString */
    //$args[‘body’] = http_build_query( $request );
    $args[‘body’] = $request;
    } else {
    $args[‘query’] = http_build_query( $request );
    }

    }

    Plugin Author Malaiac

    (@malaiac)

    @schalipp thanks for finding the bug. Your fix was included in today’s release

    @malaiac I’m experiencing the same issue using the newest plugin version (fix from above is included in the code) and the current WordPress release. I checked the API code twice, it doesn’t contain any spaces. Can you help?

    same problem with the actual version 🙁 Hope you can help an fix the problem. I have opened a new ticket for it:
    https://wordpress.org/support/topic/deepl-translates-according-to-the-logfile-but-load-icon-rotates-all-the-time/

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Translate button not doing anything’ is closed to new replies.